mobilcar

Utilisateur open source
  • Content count

    21
  • Joined

  • Last visited


Community Reputation

0 Neutral

About mobilcar

  • Rank
    Membre

mobilcar's Activity

  1. mobilcar added a post in a topic Améliorer Peel Shopping   

    Désolé, je ne connaisais pas les carractéristiques de ce produit. Premium 3, c'est la version payante n'est-ce pas ?

    Je pensais que toutes les versions étaient basées sur shopping et que seuls quelques modules complémentaires et l'install + le graphisme étaient payants.


    bon, ce sont des idées en varc, mais si c'est déjà développé ...
    • 0
  2. mobilcar added a post in a topic design du site   

    Le message s'adressait à Bénédict dont l'url est dans le premier message de ce post

    elle à visiblement chargé OsCommerc, mais elle n'a mis aucune sécurité.

    donc, si tu ajoute le répertoire "admin" à sont adresse tu accèdes à tous ses paramétrage ... C'est relativement dangeureux, non ?
    • 0
  3. mobilcar added a post in a topic design du site   

    Alors, tu as abandoné PEEL ?

    Attention, si tu tiens à ton site, tu devrais renomé ton répertoire "ADMIN" et créer un .hatcces
    • 0
  4. mobilcar added a post in a topic Votre avis sur mon site   

    Très très beau

    Je sent que je vais m'intéressé au CSS.
    • 0
  5. mobilcar added a post in a topic probleme de session   

    J'ai déjà eut le problème suivant :

    1/ Je m'identifie et là, je me trompe de mot de passe !

    2/ J'ai la page d'identification qui se réaffiche.

    3/ Je tappe le bon mot de passe et je fait OK

    et là, j'ai la page d'identification qui se réaffiche ... :blink:

    4/ j'ai la présence d'esprit de rafraichir la page ... et là, la bonne page s'affiche ! je suis en fait loggé.

    donc, vérifie si ce n'est pas tout simplement un problème de rafrichissement de ta page !

    (j'ai eut la même chose avec un message d'erreur qui s'affichait toujours en erreur sur la ligne 77 alors que j'avais inséré des codes et que l'erreur en été arrivée à la ligne 88 ... (en rafraichissant c'était bon)

    donc vois ça, on ne sais jamais.
    • 0
  6. mobilcar added a post in a topic Pas de connexion Admin   


    quand j'ai installé, j'ai mis info@pell comme mail d'administrateur
    et là, le log marchait

    Ensuite, avant de créer un autre admi, j'ai changer le mail dans les variables du site et là, plus moyen de me logger, que ce soit avec info@peel ou l'autre mail

    Je t'assure avoir fait deux fois la même install comme ça et j'ai reproduit le même bug.

    tu es certain que le mail de l'admi (à l'install) ne serait pas stocké dans la même BD que le mail des membres ?

    Auquel cas il serait possible qu'il y ai confusion en cas de modif lorsqu'il n'y a qu'un membre ayant les droits d'admi avec le même mail que dans l'admi indiqué dans les variables ? Exemple : effacement du mail info@peel.fr dans la BD

    Il faudrait tenté de reproduire ce cas de figure de ton coté.
    • 0
  7. mobilcar added a post in a topic Insertion banières rotative   

    Tu as vu que ton site est bourré d'erreurs.

    C'est certainement un problème de connexion à la BD (ou de chemin d'accès)

    Est-ce que chez toi il s'affiche bien ?
    • 0
  8. mobilcar added a post in a topic Améliorer Peel Shopping   

    Quelques idées en vrac (jai pas vérifié, certaines fonctions sont peut-être déjà prévues)

    1/
    GESTION DES CONTACTS
    gestionnaire de contact (clients) avec fonction news letter (envoi de promo etc)

    GESTION DE STOCK ET D'APPRO
    2/ gestionnaire de commande d'approvisionnement :

    Je travaille en stock à flux tendu et je commande mes produits en fonction des achats effectués sur mon site
    donc il me faut une fonction qui va comptabiliser la quantité de chaque article présent dans les commandes "non traitées". Comme ça, je sort cette liste et je l'envoi directement à mon fournisseur par mail. Il faudrait en complément définir des états pour les commandes: (indépendemment du règlement client)
    Commande effectuée (par le client) "à traiter"
    Articles comandées (au fournisseur) "en commande"
    Articles reçus (de la part du fournisseur) "entré au stock"

    Les articles "à traiter" se déduisent automatiquement du stock
    Articles "en commande" (fournisseur) n'ont pas d'influence sur le stock
    Articles reçus s'ajoutent au stock

    Si l'ont veut être encore plus pro, on ajoute la notion de quantité mini de conditionnement sur les articles :
    Le fournisseur peut très bien vendre certains articles par boites de dix, alors que je les vends à l'unité.
    du coup, si je lance une commande fournisseur, si j'en vend 8, je dois en acheter au moins dix. Donc j'ai un solde de 2 en stock.

    On peut aussi imaginer de placer le prix d'achat des articles et de calculer le prix de vente par rapport à une marge. Ce qui fait qu'on connaitrait la marge pour chaque commande, mais aussi on connaitrait la valeur de notre stock.

    En bref, on transforme PEEL en application de vente, mais aussi de gestion (dans une certaine mesure)

    Si tu veux un cahier des charges plus précis, je regarde.
    (si l'on veut pas faire trop compliqué, on peut aussi remplacé ces fonctions par une extraction des commandes pour les balancées dans excell. (mais bon ...))


    - 3/ CUSTOMISATION
    PEEL n'utilise pas les Templates. C'est bien et c'est léger.
    Par contre, la customisation est moins aisée.

    Tout en gardant le même système qu'aujourd'hui, on pourrait imaginer une page de saisie des couleurs, des cadres, d'upload des logos, fond de page etc. Il suffirait pour celà de tranformer toutes les couleurs qui sont en dur dans les sources, en variables pilotées par ce nouveau menu. Optionnellement, les variables seraient ensuite envoyées dans les fichiers respectifs concernés "en dur" pour éviter d'alourdir le chargement des pages (pour ne plus passer à chaque chargement par la page "pilote de customisation".


    - 4/INTEGRATION CMS POSTNUKE
    J'ai utilisé un excellent CMS pour faire mon site (en construction) c'est POSTNUKE.
    Il y a une communauté Française très dynamique qui s'en occupe. http://postnuke-france.org
    PEEL pourrait très avantageusement devenir un module "intégrable" à POSTNUKE.
    Pour celà, il suffit d'ajouter un script qui récupère les mots de passe et droit d'utilisateurs de PostNuke et faire quelques adaptations. On pourrait notament déplacer le menu de Peel vers un bloc menu de PostNuke.
    Le seul soft de commerce en ligne compatible PostNuke est assez lour et il n'éxiste qu'en Anglais et Allemand. Ce serait aussi une formidable promo pour les autres versions de PEEL.

    Attention, comme pour la plupart des softs, dans PostNuke il faut un pseudo et un mot de passe et non un mail et un mot de passe ! La modif ne doit pas être très compliquée !

    La seule chose, c'est que PostNuke utilise les Templates, mais bon, il doit bien y avoir une solution, par exemple en facilitant le choix des couleurs pour les coordonnées avec la chartre graphique du Template de PN.

    Voir aussi pour la gestion des langues. (pas obligatoire)

    - 5/ REDIMENSIONNEMENT IMAGES :
    Les dimensions des images à l'écran est figée, ce qui fait que lorsque l'on met une image disproportionnées (beaucoup plus large que haute), et ben l'image est complètement déformée.
    Il éxiste de très bons scripts de redimensionnement des images à l'ide de la librairie GD2 (installées sur la plupart des serveurs). Ca donne un bien meilleur résultat.

    On peut s'inspirer du script inclus à PN_Z_Classified qui est un soft de petites annonces compatible PostNuke et dont le script est très léger et efficace pour la création de vignettes.

    Exemple : http://www.mobilcar-france.fr/mobilcar/index.php

    Rubrique "Nos Occasions" (site en cours de réalisation), lien vers PN_Z_classified en bas de page annonce (Technivore)

    Bon, si certaines fonctions que je propose t'intéresse, je peut développer les caheirs des charge pour te donner une idée plus précise.

    En espérant que tu pourra me développer tout ça pour dimache prochain :blink:

    cordialement
    • 0
  9. mobilcar added a post in a topic correction peel   

    Je ne trouve pas cette ligne.
    Faut-il l'ajouter complètement oùest-ce une modif ?

    tu l'as à quelle ligne ?

    <p>
    <textarea style="width:100%" rows="10" name="description" id="description" class="formulaire1"><?php echo $frm['description']?></textarea>
    </p>
    • 0
  10. mobilcar added a post in a topic Pas de connexion Admin   


    Mais oui, j'ai compris, je ne conteste pas la procédure.

    Ce que je dit, c'est pas le problème du mail d'administrateur ou autre, mais c'est le problème du plantage du logiciel lorsque l'on modifie le mail de l'administrateur dans les variables du site.

    Pour moi, une application qui plante c'est pas normal, qu'elle soit en open source ou pas.

    Et ça, c'est facile à comprendre, mais vous n'avez pas l'air de comprendre le but de mon message.

    Avez-vous tenté de reproduire ce bug ou pas ?
    si chez vous ça ne plante pas, c'est que j'ai un bug quelque part
    si chez vous ça plante aussi, c'est qu'il y a un bug dans toutes les versions installées ...

    (je précise que j'ai fait tous les correctifs indiqués sur le forum et que mon application fonctionne très bien, sauf que ... ça m'énerve qu'on puisse si facilement planter )

    J'ai réitéré et ça a encore planté (juste pour le fun quoi !)

    Cordialement
    • 0
  11. mobilcar added a post in a topic Pas de connexion Admin   

    Merci pour ta réponse.

    Même si les pages sont idépendantes, la manip m'à bloqué le système. C'est pourquoi je l'ai signalé car, même si c'est une démarche pas commune (car en principe on fait comme tu dis), le fais de changer l'Email de l'administrateur dans le panneau des variables du site provoque un bug !

    Donc, il n'est pas impossible qu'il n'y ai qu'une seule variable genre MAIL_ADMI ou autre commune aux deux pages, ce qui causerait ce malaise.

    Il faudrait que vous testiez comme expliqué dans mon message et si c'est confirmé, il faut absolument modifier car c'est un problème peu rassurant !

    C'était une alerte surtout déstinée à ce que chacun puisse vérifier et voir comment résoudre le problème (dans un but d'amélioration du soft).

    cordialement
    • 0
  12. mobilcar added a post in a topic changer les couleur nouveauté et top vente   

    Moi, je n'ai pas de répertoire default/templates...

    Où est le fichier en question? pour changer les couleurs, ajouter un logo etc

    Version 2.9.3
    • 0
  13. mobilcar added a post in a topic Pas de connexion Admin   

    J'ai réussi à faire fonctionner la modif du mot de passe :blink:

    Mais je pense encore avoir détecter un bug dans ce système de mot de passe:

    Tentez la manipulation suivante :

    Après installation, modification du mot de passe, tout se passe bien.

    Par contre, vous allez dans la config "Variable du site" et là, vous remplcez l'adresse E_mail de l'administrateur

    Il prend bien la modif, par contre, si vous allez dans la liste des adminsitrateurs, l'adresse mail n'a pas changé (il aurais fallu la changer à partir du compte de l'adminsitrateur...) ce qui est normal puisqu'il peut y avoir plusieurs adminsitrateur ...)

    Mais, le véritable problème, c'est qu'à partir de ce moment là, il n'est plus possible de s'identifier ...

    Il doit donc y avoir un sacré mélange dans les sources entre
    - le "Mail de l'adminsitrateur" du panneau de config général de la boutique (et de l'installation)
    - le Mail d'administrateur au niveau des comptes utilisateurs
    - le mail utilisé pour le mot de passe.

    En tous cas, chez moi, ça a bloqué le système !

    (faites le teste ...)

    (encore une fois, ce ne sont pas des critiques, mais je teste à fond avant de passer du temps à personnaliser et à intégrer mon catalogue)
    • 0
  14. mobilcar added a post in a topic Pas de connexion Admin   

    En fait, ca ne marche toujours pas, mais je viens de détecter un problème qui est peut-être du au réglage de mon navigateur.

    Lorsque j'ai tenté de changer mon mot de passe, il m'à affiché le message d'erreur à la ligne 77.

    J'ai modifié le fichier et j'ai ajouté des lignes. La commande était placée à la ligne 80

    Et là, je relance et il me met toujours le message d'erreur à la ligne 77 ==> donc, je rafraichi la page et là, ça semble passer, j'ai bien le formulaire de changement de mot de passe.

    Je change donc le mot de passe, je me déconnecte et je tente de me réidentifier.

    Là, ça marche pas non plus

    N'y a-t-il pas tout simplement un gros problème de rafraichissement des pages ? Auquel cas, j'ai l'impression que les infos envoyées au soft ne seraient pasz forcément celles que l'on saisie ... mais les anciennes ???

    Ca parait idiot, mais j'ai bien l'impression qu'il y à un truc très bizzard de ce genre.

    N'y a-t-il pas une commande à ajouter quelque part dans les codes pour forcer le réfraichissement des pages ???
    • 0
  15. mobilcar added a post in a topic Pas de connexion Admin   

    Bon,ben j'ai appliqué tous les correctifs vu sur ce forum et là, ça ne fonctionne toujours pas.

    Pire, j'ai fait une réinstall complète en effaçant la BD et en remettant tout à jour et là, même avec le logging pas défaut, je ne suis plus reconnu.

    Si quelqu'un veut y regarder

    Je donne mon ftp en privé.

    si non, j'attendrais la version corrigée
    • 0

Twitter Advisto ecommerce

Facebook PEEL Shopping