Sign in to follow this  
Followers 0

Liens ne fonctionnant pas

10 posts in this topic

Posted · Report post

Bonsoir,

Toujours dans ma quète de mieux comprendre PEEL, je suis confronté à certains problèmes.

Voici un exemple, je n'arrive pas à trouver le bon code pour faire en sorte que les boutons "vider" et "commander" soient effecitfs, mais rien n'y fait.

Voici donc le code d'origine :

<div style="padding-top:50px;text-align:right">

<div align="left"><span class="Style7"><a class="normal" href="<?php echo $wwwroot?>/achat">Continuer mes achats</a> | <a class="normal" href="java script: frmsubmit('vide');">Vider la liste</a> | <a class="normal" href="java script: frmsubmit('commande');"><b>COMMANDER</b></a></span> </div>

</div>

</form></td>

</tr>

</table>

Merci pour votre aide

Cordialement

Bénédict

Share this post


: post
Share on other sites

Posted · Report post

Avez vous bien vérifier que le javascript frmsubmit est bien déclaté dans la page

Share this post


: post
Share on other sites

Posted · Report post

Avez vous bien vérifier que le javascript frmsubmit est bien déclaté dans la page

Bonjour et merci à nouveau de votre assistance.

Voici ce que j'ai sur la page concernée :

<input type="hidden" name="id[]2" value=<?php echo $prod['id]?>" />

<td class="normal"><a onclick="java script:return confirm('&Ecirc;tes-vous s&ucirc;r de vouloir enlever ce produit du panier ?');" class="normal" href="<?php echo $_SERVER['PHP_SELF']?>?func=enleve&amp;id=<?php echo $prod['id']?>"> <img src="<?php echo $wwwroot?>/images/poubelle.gif" width="25" height="25" alt="" border="0" /> </a></td>

<td class="normal"><!-- affiche le nom du produit -->

<a class="normal" href="<?php echo $wwwroot?>/achat/produit_details.php?id=<?php echo $prod['id']?>"><?php echo $prod['nom'] ?></a> </td>

<td class="normal" align="center"><input type="text" size="3" name="quantite[]2" value="<?php echo $quantite?>" onchange="java script: frmsubmit('recalc');" />

N'ayant rien touché à cette page, il y aurait-il eu un bug au départ ???

Je ne sais comment régler ce problème de commande et de vider

Merci par avance

Bénédict

Share this post


: post
Share on other sites

Posted · Report post

regarde dans la page achat/modeles/caddie.php la fonction

<script language="Javascript">

function frmsubmit(func) {

	frm = document.entryform;

	frm.func.value = func;

	frm.submit();

}	



</script>

en haut de page

Share this post


: post
Share on other sites

Posted · Report post

regarde dans la page achat/modeles/caddie.php la fonction

&lt;script language="Javascript">

function frmsubmit(func) {

	frm = document.entryform;

	frm.func.value = func;

	frm.submit();

}	

</script>

en haut de page

Bonjour,

Aussi étrange que cela puisse paraître, sans iren avoir touché à cette page, je retrouve bien la fonction mais en bas de page, et sans le } final

Cela doit jouer sur la reconnaissance fonctionnelle du "frmsubmit"

Je teste et vous tiens au courant

Merci beaucoup

Bénédict

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Aussi étrange que cela puisse paraître, sans iren avoir touché à cette page, je retrouve bien la fonction mais en bas de page, et sans le } final

Cela doit jouer sur la reconnaissance fonctionnelle du "frmsubmit"

Je teste et vous tiens au courant

Merci beaucoup

Bénédict

Bien,

Bonjour à tous,

Après un WE à avoir cherché les solutions à mon problème, je reviens vers vous car n'ayant trouvé aucune formule me permettant de me régler, je chercher aurpès de vous une solution.

Je rencontre donc toujours mon soucis concernant les fonctions "commander" et "vider" dans la page "caddie.php.

Voivi le code :

<div style="padding-top:50px;text-align:right">

<div align="left"><span class="Style7"><a class="normal" href="<?php echo $wwwroot?>/achat">Continuer mes achats</a> | <a class="normal" href="java script: frmsubmit('vide');">Vider la liste</a> | <a class="normal" href="java script: frmsubmit('commande');"><b>COMMANDER</b></a></span> </div>

</div>

Et j'ai bien en haut de page ceci :

<script language="Javascript">

function frmsubmit(func) {

frm = document.entryform;

frm.func.value = func;

frm.submit();

}

</script>

Une aide serait la bienvenue

Merci par avance

Benedict

Share this post


: post
Share on other sites

Posted · Report post

le problème estil présent sur tous les navigaeurs ?

Share this post


: post
Share on other sites

Posted · Report post

le problème estil présent sur tous les navigaeurs ?

Bonjour Paulanna,

Malheusement oui

Bénédict

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Paulanna,

Malheusement oui

Bénédict

Enlève un produit du caddie

Bonjour,

La fonction « Enlève un produit du caddie » ne fonctionne pas.

Dans la page « Votre panier » si l’on clique sur la poubelle il n’y a aucun résultat, le produit reste. Il faut vider le caddie pour tout effacer.

Peut-être avez-vous une solution.

Cordialement

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

J'ai le même problème, apparu après qu'un virus ait ajouté un iframe dans les fichiers d'index de mon site.

Depuis, le lien frm(commander) est inactif. Il recharge seulement la page /achat/caddie_affichage.php, et c'est tout.

J'ai bidouillé en remplaçant le lien java script: frmsubmit('commande') par un pointage direct sur la page achat_maintenant.php. Ça à l'air de marcher. J'ai mené à terme deux commandes avec firefox et i.e.

J'aimerais quand même corriger cela.

Savez-vous si le remplacement de lien peut poser quelque problème inattendu par ailleurs, et sinon, avez-vous la solution pour que le lien javascript fonctionne, ou ce qui a pu se passer.

Merci

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

Twitter Advisto ecommerce

Facebook PEEL Shopping