Sign in to follow this  
Followers 0

"variable" frais de port

8 posts in this topic

Posted · Report post

bonjour

suite à un changement de variable pour les frais de port, j'ai mis en "normal" 1.10 euro et en "express" 1.50 euro mais le soucis est que quand j'édite un bon de commande les frais de port en "express" ne s'affiche pas le montant est à 0 euro !!! que dois je faire?? merci beaucoup c'est urgent car j'ai des commandes sur mon site ou les personnes ne paient pas les frais de port !!!!

Share this post


: post
Share on other sites

Posted · Report post

bonjour

suite à un changement de variable pour les frais de port, j'ai mis en "normal" 1.10 euro et en "express" 1.50 euro mais le soucis est que quand j'édite un bon de commande les frais de port en "express" ne s'affiche pas le montant est à 0 euro !!! que dois je faire?? merci beaucoup c'est urgent car j'ai des commandes sur mon site ou les personnes ne paient pas les frais de port !!!!

A mon avis il y a un problème avec les virgules

Faites un echo de la requete sql qui insère la commande dans /lib/fonctions/fonctions.php et vérifier que les frais de port sont bien calculés

Share this post


: post
Share on other sites

Posted · Report post

je ne suis pas super forte dans le sql !! faire un echo ?

Share this post


: post
Share on other sites

Posted · Report post

quelqu'un peut me repondre car là mes clients ne paient pas de frais de port et c'est un manque à gagner merci

Share this post


: post
Share on other sites

Posted · Report post

je vais être plus imagé :

voilà lorsque je fais une commande et que je choisis les frais de port "express" je valide

3.gif

là j'ai le resumé de commande avec les bons frais de port que j'ai mis dans le paramétrage des variables c'est à dire 3 euros, ce qui me fait un total pour cette commande de 3,30 euros jusqu'ici tout va bien...

2.gif

Mais la suite est une catastrophe voilà ce que paient en réalité mes clients

1.gif

0,30 cts d'euros

Pouvez vous me dire où est l'erreur ? ou quels sont les fichiers à modifier pour les frais de port, MErci d'avance ;)

Share this post


: post
Share on other sites

Posted · Report post

Vous avez modifié le code et oublié de remettre le passage des variables dans la fonction cree_commande

Pensez à vérifier si vous avez un global $express, normal dans la fonction cree_commande

Pensez à vérifier que le nom des frais de port correspond bien à ces 2 variables

Share this post


: post
Share on other sites

Posted · Report post

merci de me répondre ;) mais la fonction cree_commande elle est où?

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

Twitter Advisto ecommerce

Facebook PEEL Shopping