pas de gras, italique, liens, etc..

9 posts in this topic

Posted · Report post

J'utilise Peer Shopping 3.1 et chaque fois que je veux mettre du gras, de l'italique, un lien, etc dans un descriptif de catégorie .. j'obtiens comme affichage les balises html !

Par contre dans les produits, pas de problème !

Tiens , ici aussi je vois les balises et pas le gras ...

Share this post


: post
Share on other sites

Posted · Report post

html_entity_decode

Share this post


: post
Share on other sites

Posted · Report post

html_entity_decode

Merci mais je mets ça où , dans quel fichier ?

Et je répète que ça ne le fait que dans "catégories".

Share this post


: post
Share on other sites

Posted · Report post

Merci mais je mets ça où , dans quel fichier ?

Et je répète que ça ne le fait que dans "catégories".

Share this post


: post
Share on other sites

Posted · Report post

Vu !! J'ai compris qu'il fallait que je remplace 2 lignes dans le fichier. Je l'ai fait mais j'ai une nouvelle inexplicable "panne" : dans 2 catégories je peux faire des changements, mettre du gras, etc.. mais dans deux autres chaque fois que je modifie, supprime, etc .. après "sauvegarder" rien ne se passe et ça revient comme avant !!

Par exemple si la phrase est "bonjour ça va bien" et que je supprime "bien", je clique sur "sauvegarder les changements" mais le "bien " est toujours présent !!! Je ne vois pas pourquoi 2 catégories sont "bloquées" et pas les deux autres ..

Question 2 : pourquoi ici je vois aussi les balises et pas le résultat ?

Share this post


: post
Share on other sites

Posted · Report post

Je confirme que la modif des 2 lignes ne .... fonctionne pas et empêche d'éditer par la suite !!!

Alors, pourquoi le html fonctionne dans les "produits" et pas dans les "catégories" ?

Share this post


: post
Share on other sites

Posted · Report post

Encore moi !! En fait la modif fonctionne mais ce qui n'est pas dit c'est que la chaîne .htmlspecialchars($frm['description'] est DEUX fois dans la page categories.php !! Ligne 244 et 256 . Et il faut donc remplacer par .html_entity_decode($frm['description'],

Share this post


: post
Share on other sites

Posted · Report post

 

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping