Sign in to follow this  
Followers 0

Shopping V4 Timeout

10 posts in this topic

Posted · Report post

Bonjour à tous,

Installation réussie mais dès le lancement de la page d'accueil j'obtiens un timeout et le message suivant :

Warning: getimagesize(http://127.0.0.1/Ma boutique/upload/231108_184549_PEEL_zaUSks.jpg) [function.getimagesize]: failed to open stream: HTTP request failed! in C:\Program Files\EasyPHP 3.0\www\Ma boutique\lib\fonctions\fonctions.php on line 1905

Fatal error: Maximum execution time of 30 seconds exceeded in C:\Program Files\EasyPHP 3.0\www\Ma boutique\lib\fonctions\fonctions.php on line 1905

Comme vous le voyez install sous Easyphp et problème sans doute (???) liè au CHMOD 755. Je n'ai pas trouvé la marche à suivre en local (autorisations propriétaire refusées ?). Pourriez vous m'indiquer la marche à suivre SVP.

Merci

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Avez-vous vérifié si dans votre répertoire "upload" vous avez bien une image nommée "231108_184549_PEEL_zaUSks.jpg" ?

Il se peut que toutes vos images n'aient pas été correctement téléchargées par le client FTP que vous avez utilisé.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Avez-vous vérifié si dans votre répertoire "upload" vous avez bien une image nommée "231108_184549_PEEL_zaUSks.jpg" ?

Il se peut que toutes vos images n'aient pas été correctement téléchargées par le client FTP que vous avez utilisé.

Merci de votre interet, pas d'image dans le dossier (vide), pas eu le temps de faire quoi que ce soit, je n'obtiens pas même l'ouverture complète de index.php. Pas de téléchargement FTP, suis en local.

Quand aux droits ils sont corrects, vérifiés lors de l'install, cela ressemble pourtant à une boucle à ce niveau....

J'en perds mon peu de latin.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour à tous et toutes

Où se trouvent les images du champ image1 des fichiers produit et article. Le dossier UPLOAD est vide, le dossier IMAGES ne contient aucune correspondance. Il semblerait que le timeout de mon précédent post soit liè à ces absences...

Warning: getimagesize(http://127.0.0.1/Ma boutique/upload/231108_184549_PEEL_zaUSks.jpg) [function.getimagesize]: failed to open stream: HTTP request failed! in C:\Program Files\EasyPHP 3.0\www\Ma boutique\lib\fonctions\fonctions.php on line 1905

Fatal error: Maximum execution time of 30 seconds exceeded in C:\Program Files\EasyPHP 3.0\www\Ma boutique\lib\fonctions\fonctions.php on line 1905

L'image 231108_184549_PEEL_zaUSks.jpg correspond à la 1ère ligne de la table produit champ image1. Le dossier upload est vide à l'origine ! Sans cette info je ne peux accèder à l'admin

Merci de vos réponses

Share this post


: post
Share on other sites

Posted · Report post

Bonjour à tous,

Installation réussie mais dès le lancement de la page d'accueil j'obtiens un timeout et le message suivant :

Warning: getimagesize(http://127.0.0.1/Ma boutique/upload/231108_184549_PEEL_zaUSks.jpg) [function.getimagesize]: failed to open stream: HTTP request failed! in C:\Program Files\EasyPHP 3.0\www\Ma boutique\lib\fonctions\fonctions.php on line 1905

Fatal error: Maximum execution time of 30 seconds exceeded in C:\Program Files\EasyPHP 3.0\www\Ma boutique\lib\fonctions\fonctions.php on line 1905

Comme vous le voyez install sous Easyphp et problème sans doute (???) liè au CHMOD 755. Je n'ai pas trouvé la marche à suivre en local (autorisations propriétaire refusées ?). Pourriez vous m'indiquer la marche à suivre SVP.

Merci

UP

Pour avancer j'ai supprimé le contenu des champs image1, plus de timeout. Mais je ne peux m'identifier, l'utilisateur info@peel.fr n'existe pas dans la table utilisateur. Même en le créant en direct par mysql je suis rejeté. Codage md5 obligatoire sur mot de passe admin ??? Je suis coincé !

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

je vous conseille de vous créer un compte via le front-office comme un utilisateur lambda, de vous rendre ensuite dans votre base de données et de modifier dans la table peel_utilisateurs l'enregistrement concernant le compte que vous venez de créer en remplaçant dans le champ "priv" le mot "util" (qui indique des droits utilisateur) par "admin" (qui indique que le compte possède à présent des droits administrateur).

Une fois cela fait, déconnectez-vous puis reconnectez-vous pour que vos nouveaux droits de compte administrateur soient pris en compte.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

je vous conseille de vous créer un compte via le front-office comme un utilisateur lambda, de vous rendre ensuite dans votre base de données et de modifier dans la table peel_utilisateurs l'enregistrement concernant le compte que vous venez de créer en remplaçant dans le champ "priv" le mot "util" (qui indique des droits utilisateur) par "admin" (qui indique que le compte possède à présent des droits administrateur).

Une fois cela fait, déconnectez-vous puis reconnectez-vous pour que vos nouveaux droits de compte administrateur soient pris en compte.

Bonjour,

Merci de la réponse, j'avais déjà essayé la manoeuvre MAIS

Parse error: parse error, expecting `','' or `';'' in C:\Program Files\EasyPHP 3.0\www\Ma boutique\utilisateurs\enregistrement.php on line 186

lors de l'inscription.

Une idée ?

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Pourriez-vous ouvrir le fichier "enregistrement.php" du dossier "utilisateurs" avec votre éditeur et copier / coller le code se trouvant aux alentours de la ligne 186 ? (par exemple de la ligne 180 à 190)

D'après le message d'erreur qui vous est retourné, il s'agit de l'absence d'une virgule ou d'un point-virgule.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Pourriez-vous ouvrir le fichier "enregistrement.php" du dossier "utilisateurs" avec votre éditeur et copier / coller le code se trouvant aux alentours de la ligne 186 ? (par exemple de la ligne 180 à 190)

D'après le message d'erreur qui vous est retourné, il s'agit de l'absence d'une virgule ou d'un point-virgule.

Bonjour,

Il est exact qu'il manquait un ";" à l'echo de la ligne 184 mais il reste un problème sur l' INSERT INTO

function insere_utilisateur(&$frm) {

global $support;

$mot_passe_bak = trim(htmlspecialchars($_POST['mot_passe']));

$mot_passe = md5($frm['mot_passe']);

$newsletter = valide($frm['newsletter']);

$commercial = valide($frm['commercial']);

$naissance = ereg_replace('^([0-9]{1,2})/([0-9]{1,2})/([0-9]{2,4})$','\\3-\\2-\\1', $frm['naissance']);

$sql = "

INSERT INTO peel_utilisateurs (

email

, mot_passe

, priv

, civilite

, prenom

, nom_famille

, societe

, naissance

, telephone

, portable

, adresse

, code_postal

, ville

, pays

, date_insert

, date_update

) VALUES (

'".strtolower(htmlspecialchars($frm['email'], ENT_QUOTES))."'

,'$mot_passe'

,'util'

,'".vb($frm['civilite'])."'

,'".strtoupper(htmlspecialchars($frm['prenom'], ENT_QUOTES))."'

,'".strtoupper(htmlspecialchars($frm['nom_famille'], ENT_QUOTES))."'

,'".strtoupper(htmlspecialchars($frm['societe'], ENT_QUOTES))."'

,'$naissance'

,'".$frm['telephone']."'

,'".$frm['portable']."'

,'".htmlspecialchars($frm['adresse'], ENT_QUOTES)."'

,'".$frm['code_postal']."'

,'".htmlspecialchars($frm['ville'], ENT_QUOTES)."'

,'".htmlspecialchars($frm['pays'], ENT_QUOTES)."'

, now()

, now()

)";

echo $sql;

/* Ajoute le nouvel utilisateur à la base */

$qid = mysql_query($sql) or DIE('Une erreur de connexion &agrave; la base s est produite ' . __LINE__ . '.<p>' . MYSQL_ERROR());

Message obtenu : Une erreur de connexion à la base s est produite 186.

Field 'message' doesn't have a default value

Manquerait-il un ALTER à la table ?

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Il est exact qu'il manquait un ";" à l'echo de la ligne 184 mais il reste un problème sur l' INSERT INTO

function insere_utilisateur(&$frm) {

global $support;

$mot_passe_bak = trim(htmlspecialchars($_POST['mot_passe']));

$mot_passe = md5($frm['mot_passe']);

$newsletter = valide($frm['newsletter']);

$commercial = valide($frm['commercial']);

$naissance = ereg_replace('^([0-9]{1,2})/([0-9]{1,2})/([0-9]{2,4})$','\\3-\\2-\\1', $frm['naissance']);

$sql = "

INSERT INTO peel_utilisateurs (

email

, mot_passe

, priv

, civilite

, prenom

, nom_famille

, societe

, naissance

, telephone

, portable

, adresse

, code_postal

, ville

, pays

, date_insert

, date_update

) VALUES (

'".strtolower(htmlspecialchars($frm['email'], ENT_QUOTES))."'

,'$mot_passe'

,'util'

,'".vb($frm['civilite'])."'

,'".strtoupper(htmlspecialchars($frm['prenom'], ENT_QUOTES))."'

,'".strtoupper(htmlspecialchars($frm['nom_famille'], ENT_QUOTES))."'

,'".strtoupper(htmlspecialchars($frm['societe'], ENT_QUOTES))."'

,'$naissance'

,'".$frm['telephone']."'

,'".$frm['portable']."'

,'".htmlspecialchars($frm['adresse'], ENT_QUOTES)."'

,'".$frm['code_postal']."'

,'".htmlspecialchars($frm['ville'], ENT_QUOTES)."'

,'".htmlspecialchars($frm['pays'], ENT_QUOTES)."'

, now()

, now()

)";

echo $sql;

/* Ajoute le nouvel utilisateur &agrave; la base */

$qid = mysql_query($sql) or DIE('Une erreur de connexion &agrave; la base s est produite ' . __LINE__ . '.<p>' . MYSQL_ERROR());

Message obtenu : Une erreur de connexion à la base s est produite 186.

Field 'message' doesn't have a default value

Manquerait-il un ALTER à la table ?

Problèmes règlés !!!

Mysql à écrit:

BLOB/TEXT column 'message' can't have a default value (Errno: 1101)

Pour infos aux possesseurs de EASYPHP 3.0

Apache/2.2.11 (Win32) PHP/5.2.8

Version du client MySQL: 5.0.51a

phpmyadmin 3.1.1, sqlitemanager 1.2.0

Avec les dernières versions de MySQL, vous pouvez avoir des problèmes pour installer diverses applications php et ce messages cité en haut peut apparaître.

La solution : modifier le fichier SQL.ini

Il faut commenter la ligne : sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

c’est-a-dire : #sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"

Apres, ca roule... Merci de vos efforts, je vais pouvoir enfin entrer en tests. Bonne journée

Share this post


: post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

Twitter Advisto ecommerce

Facebook PEEL Shopping