Erreur butterflive : nécessité d'activer allow_url_fopen

21 posts in this topic

Posted · Report post

Bonsoir

j'ai créé un compte butterflive, reçu le mail de confirmation et activé avec le lien qu'ils ont donné... ça a marché

Maintenant, dans le back office, je souhaite active le module dans peel shopping.

Je vais donc dans les options, je clique que j'ai déjà un compte, je rentre l'adresse mail, et là, message d'erreur :

Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/5/d334204221/htdocs/modules/butterflive/admin/butterflive.php on line 97

Warning: file_get_contents(https://www.butterflive.com/remote/getKeyByMail?mail=contact%40jl-transferts-numeriques.fr) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /homepages/5/d334204221/htdocs/modules/butterflive/admin/butterflive.php on line 97

Une erreur est survenue lors de la configuration de Butterflive. Veuillez réessayer plus tard.

Y'a t'il des trucs à installer ? une clé à insérer quelque part ?

merci pour l'info

cordialement

JL

Share this post


: post
Share on other sites

Posted · Report post

Jean-Luc,

Comme l'erreur "URL file-access is disabled in the server configuration" l'indique , c'est allow_url_fopen qui n'est pas activé sur votre serveur.

Habituellement allow_url_fopen est activé sur les hébergements PHP, mais ce n'est pas systématique.

C'est expliqué ici :

http://forum.phpfrance.com/faq-tutoriels/u...tion-t7699.html

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Pour information, dans la prochaine vers de PEEL Shopping il y aura un test à l'installation sur l'activation ou non de allow_url_fopen.

Mais pour ceux qui comme vous font une migration, ça ne changera rien puisque vous ne repassez pas par une installation complète.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Gilles

Merci comme d'habitude pour votre réponse très rapide et efficace.

Donc grâce aux infos que vous m'avez communiqué, j'ai trouvé un truc sur la FAQ de mon hébergeur 1and1 (hébergement mutualisé, donc pas accès au php.ini... :

"En mettant en place un fichier php.ini comme indiqué dans notre FAQ contenant l’information ci-dessous, vous allez pouvoir rétablir l’accès externe aux URL :

allow_url_fopen = On

Cette procédure reste cependant déconseillée pour des raisons de sécurités et nous vous recommandons d’adapter vos scripts pour la récupération des données distantes à l’aide de la fonction fsockopen()."

donc quelques questions...

Ce fichier php.ini que je vais créer, faut il le mettre dans TOUS les répertoires ou seulement sur la racine ?

Est ce vraiment vraiment vraiment dangereux d'activer ce paramètres ?

Merci pour votre aide

cordialement

JL

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Jean-Luc,

Le fait d'ouvrir un socket avec fsockopen est à mon sens pas moins dangereux que allow_url_fopen car ça permet facilement de créer un serveur en PHP, un serveur IRC par exemple. Le risque avec allow_url_fopen est d'avoir des include de fichiers distants, donc ça peut permettre d'altérer le fonctionnement d'un site en changeant un path par exemple. C'est pour cela dans PEEL qu'on précise toujours $dirroot dans tous les chemins d'accès aux fichiers locaux.

Je ne me souviens plus chez 1&1 si un php.ini doit être mis à la racine ou dans chaque répertoire également, testez, et vous allez bien voir. Si c'est chaque répertoire, vous devez le mettre dans chaque répertoire contenant des fichiers PHP, donc achat/, utilisateurs/, les répertoires de modules, ... => si c'est le cas, un changement d'hébergeur me paraîtrait conseillé.

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Gilles

bien, j'ai créé un fichier php.ini, et j'ai commencé à le mettre à la racine...

ça a pas marché, toujours le même message d'erreur

je l'ai alors copié dans TOUS mes répertoires contenant des .php, et maintenant ça marche !! je me suis connecté à butterflive...

Mais je vois pas à quoi ça sert !!!! :) :P

merci en tous cas

cordialement

JL

UP !!!

je viens de lire en détail sur le site butterflive, et ils disent qu'il y a un code de suivi butterfly, utiliser le code asynchrone, donc de copier coller dans le body la séquence :

<script type="text/javascript">

bflOptions = {

key: "Votre clef Butterflive",

src: "http://api.butterflive.com/butterflive.js"

};

(function() {

var btf = document.createElement('script'); btf.type = 'text/javascript'; btf.async = true;

btf.src = bflOptions.src;

var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(btf, s);

})();

</script>

en remplaçant key par notre clé privée... Je veux bien, mais on le colle ou ce morceau de code ? est il déjà compris dans peel ?

merci pour votre renseignement gilles

Share this post


: post
Share on other sites

Posted · Report post

Jean-Luc,

Normalement il n'y a rien à faire question tag, tout est déjà inclus dans le module qui est dans la 6.1.

Donc utilisez l'administration "Paramètres tracking et Chat" :

http://premium.peel.fr/modules/butterflive...butterflive.php

et connectez-vous au compte que vous avez créé.

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Gilles

ok si tout est déjà configuré. Mais voilà ce que je constate:

-J'ai bien tout : identifiant, key...

-Je vais sur l'admin de mon site, >paramètres treacking et tchat : rectangle rouge : Attention! Votre site n'est pas autorisé dans votre compte Butterflive. Cliquez ici pour activer ce site.

-Je clique : il me demande autorisation et mot de passe... je rebtre tout ça et je clique sur activer le site...

-ça m'affiche un rectangle vert : Votre site web est maintenant autorisé dans votre profil Butterflive. Si vous avez déjà installé la console Butterflive sur votre PC, vous devrez la redémarrer pour prendre en compte ces modifications.

-Je clique dessous sur "retour à l'écran de configuration"

-et là, il me remet le cadre rouge "Attention! Votre site n'est pas autorisé dans votre compte Butterflive. Cliquez ici pour activer ce site."

Du coup, je ne sais pas si butterflive est activé sur mon site vous comprenez !?

En plus, ce que je comprends pas, c'est que sur le site butterflive, quand ils disent de copier le bout de code dans le body, ils précisent qu'il faut entrer la clé qui nous a étét envoyée par mail... Or moi, j'ai bien cette clé, et je ne l'ai rentrée nulle part !!!

Je précise que c'est pas une install propre que j'ai fais de peel 6.1, mais une migration... Enfin... J'ai pris tous les fichiers de la 6.1, j'ai corrigé les quelques fichiers de la 6.1 ou j'avais des modifs (invoice.php pour l'affichage des données de la société, le display.php pour des boutons du menu du haut....) et j'ai tout rebalancé sur mon serveur vide...

Une aide ?

Share this post


: post
Share on other sites

Posted · Report post

Bonjour

voilà l'état de mon avancée concernant butterflive...

en l'état actuel des choses, ça marche pas... Même avec un compte créé, fonctionnel, une connection possible sur leur site à mon compte, un site défini dans le compte, l'interface sur le PC reste désespérément vide :)

La manipulation sur le backoffice reste toujours la même... identification avec adresse mail et password, il dit que c'est ok, qu'on est ascivé; on revient sur la fenêtre de paramètre tracking et tchat et là de nouveau, le message d'erreur comme quoi on n'est pas autorisé dans le compte butterflive... C'est à n'y rien comprendre...

Donc dans un désespoir complet, j'ai essayé quelque chose. J'ai pris le bout de code cité plus haut et je l'ai commé dans le tag analytic, et mettant ma clé dans le code à l'endroit prévu... Et là, ho surprise, ça y est !! quand je surfe sur mon propre site, j'ai des statistiques temps réel qui apparaissent dans l'interface butterflive du PC !!

Pourtant, j'ai toujours le même message d'erreur dans le backoffice comme quoi je ne suis pas activé...

Donc bug ? problème de mon côté ??

un ptit coup d'aide serait le bienvenu Gilles :P

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

J'ai fait remonter hier le sujet aux bonnes personnes, vous aurez une réponse éclairée sur ce sujet très bientôt, car de mon côté ce n'est pas mon sujet d'expertise.

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Jean-Luc,

Je suis le responsable de l'intégration entre Butterflive et Peel.

Je regarde ce qui se passe très vite, j'espère trouver une solution d'ici ce soir!

Cordialement,

David.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Jean-Luc,

Après étude, il s'agit en fait d'une anomalie d'affichage de notre part.

Le compte est bien autorisé, mais l'interface d'administration dans Peel s'obstine à dire qu'il y a un problème d'autorisation alors qu'il n'y en a pas.

Nous allons travailler sur un "fix", mais comme vous l'avez surement déjà compris, cela ne vous empêche pas d'utiliser Butterflive avec Peel dès à présent!

N'hésitez pas à nous faire des retours sur l'utilisation de Butterflive!

Cordialement,

David.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour !

bien compris et merci pour votre recherche.

Mais y'a toujours un problème malgré tout... Si on estime que malgré le message d'erreur, on est bien connecté, hé bien tel quel ça ne fonctionne pas... Il a fallut que je rajoutte les lignes de code que butterflive donne sur leur site (en synchrone pour ma part) dans le code Tag analytique de la gestion de peel pour que je puisse enfin obtenir un suivi analytique de mon site. Vous voyez le problème ??

Autrement, ce qui serait bien, c'est que vous expliquiez pour les débutants comme moi comment rajoutter un bouton de tchat sur le site, comme ils le décrivent sur butterflive, avec soit tchat si l'agent est connecté, soit envoyer un email pour le contact et dans ce cas, rediriger vers la page contact...

Merci pour votre aide

cordialement

Share this post


: post
Share on other sites

Posted · Report post

Rebonjour Jean-Luc!

Ok, je pense que le problème d'affichage est résolu.

Si vous vous connectez à l'admin, vous devriez voir une belle boite verte disant:

"La configuration des autorisations dans Butterflive est correcte."

Concernant l'autre point, là, c'est plus bizarre :s

J'ai regardé votre site, et effectivement, vous avez parfaitement utilisé le tag analytique pour rajouter Butterflive.

Cependant, normalement, le tag aurait du être rajouté par le module. J'ai testé en local et sur le serveur de démo de Peel, et le bout de code Butterflive est correctement rajouté par le module.

Ce que je pense, c'est que le bout de code devait être bien rajouté mais que les autorisations n'ont pas été prises en compte correctement par le widget (l'application Butterflive sur votre PC).

Dans ce cas, il faut redémarrer l'application pour qu'elle "réinitialise" les autorisations, ce que vous avez peut être fait après avoir mis le tag Analytique. Ceci n'est cependant qu'une supposition.

Je serais curieux de savoir si en supprimant le tag Analytique et en activant le module (via la checkbox "Activer Butterflive" dans l'admin), vous arrivez à faire fonctionner le module.

En tout cas, encore merci pour nous avoir pointé le bug!

Cordialement,

David

Share this post


: post
Share on other sites

Posted · Report post

Bonsoir David

J'ai pas vraiment compris ce que vous dîtes... En ne modifiant rien de mon côté, je devrai maintenant avoir le carré vert qui s'affiche m'indiquant la bonne activation du compte ? Mais si je ne modifie pas le code de mon côté, comment la correction peut elle se faire ? Que faut il corriger ? ou ?

parce que j'ai toujours le cadre rouge "Attention! Votre site n'est pas autorisé dans votre compte Butterflive. Cliquez ici pour activer ce site.", même une fois que j'ai rentré le mail et le pass d'activation...

De plus, J'ai également tenté de supprimer le code rajoutté du tag analytic et j'ai tout relancé... là, ça marche plus du tout... plus de suivi analytique...

pourtant, l'activation est bien effective côté butterflive pour mon site http://www.jl-transferts-numeriques.fr

J'ai remis de nouveau le code asynchrone dans le tag, et là, ça remarche à merveille !! et même le tchat que j'ai essayé sur 2 PC différents...

là je suis complètement perdu :)

Comment se fait il que votre code déjà intégré dans peel ne fonctionne pas ?

Déjà, pouvez vous diffuser le fichier corrigé, ou indiquer dans quel fichier et quelle ligne corriger par quoi ?

Je vous remercie grandement pour votre boulot formidable

cordialement

Jean-Luc

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Jean-Luc,

Désolé si je ne suis pas clair.

Nous allons procéder par étape.

Quand je dis que j'ai corrigé le code pour que l'affichage des autorisations fonctionne (pour que vous ayez une boite verte au lieu de rouge), je ne l'ai pas corrigé dans Peel, mais du coté des serveurs Butterflive.

Donc normalement, sans rien toucher, si vous allez dans la section "Tracking & Chat" de l'interface d'administration de Peel, vous devriez voir une boite verte disant que les autorisations sont correctes.

Est-ce que vous pourriez me confirmer que c'est bien le cas aujourd'hui? Si ça n'est pas le cas, il faut que je me remette au boulot sur les autorisations :s

Une fois que nous aurons résolu ce problème d'autorisation, nous passerons à l'activation de Butterflive sans Tag Analytique!

David.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour David !

j'espère que vous avez passé un excellent week end ensoleillé !! :)

bon, je viens de retester ce matin,

Backoffice>Gestion du site>Paramètres Tracking et tchat...

là déjà, rectangle rouge :

Attention! Votre site n'est pas autorisé dans votre compte Butterflive. Cliquez ici pour activer ce site.

Sue cette fenêtre, y'a aussi :

Votre identifiant Butterflive: contact@jl-transferts-numeriques.fr

la case "activer butterflive" est cochée.

Je clique donc pour activer le site. Je tombe sur la fenêtre qui demande mail et mot de passe. Le mail est déjà renseigné. Je rentre le pass...

Je clique sur "activer le site".

là il me met un rectange vert :

Votre site web est maintenant autorisé dans votre profil Butterflive. Si vous avez déjà installé la console Butterflive sur votre PC, vous devrez la redémarrer pour prendre en compte ces modifications.

jusque là, tout se passe bien....

je clique sur "retour à l'écran de configuration"

là il réfléchi (icone des petits points qui tournent) et enfin, il me remet dans un rectangle rouge : Attention! Votre site n'est pas autorisé dans votre compte Butterflive. Cliquez ici pour activer ce site.

voilà... je vous ai donné en détail toutes les manip pas à pas que j'ai faites... là le tracking et le tchat ne fonctionnent pas si je n'ai pas rajoutté dans le tag le bout de code butterflive....

par contre, avec ce bout de code, ça marche nickel !

voilà les infos

merci pour votre aide

bon courage

cordialement

Jean-Luc

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Jean-Luc,

Nous avons du mal à reproduire le bug que vous rencontrez et nous allons avoir besoin de votre aide!

Afin de nous aider à déterminer l'origine du problème, pouvez vous créer un fichier "test.php" dans le répertoire "modules/butterflive/admin" de Peel et y copier ce code php:

<?php
define('IN_PEEL_ADMIN', true);
include("../../../configuration.inc.php");
require_once("../include/add_json_functions.php");
require_once("config.php");
necessite_identification();
necessite_priv("admin");

var_dump($_SERVER["HTTP_HOST"]);
echo"<br/>";
var_dump(phpversion());
echo"<br/>";
$res = query("SELECT value FROM peel_butterflive WHERE param = 'key'");
$resultat = mysql_fetch_row($res);
$key = $resultat[0];
$request_url = BUTTERFLIVE_WEBSITE_URL."remote/key_info?key=".urlencode($key);
var_dump($request_url);
echo"<br/>";
$resultat = json_decode(file_get_contents($request_url));
var_dump($resultat);[/codebox]

Ainsi, la page http://jl-transferts-numeriques.fr/modules.../admin/test.php devrait vous afficher une page semblable à celle ci, contenant quelques informations non sensibles:

[codebox]string(9) "127.0.0.1"
string(6) "5.2.11"
string(66) "https://www.butterflive.com/remote/key_info?key=DBFDD40CBCA01F27DA"
object(stdClass)#2 (3) { ["active"]=> bool(true) ["pro"]=> bool(false) ["urls"]=> array(1) { [0]=> string(38) "http://www.jl-transferts-numeriques.fr" } }

Pourriez vous poster ici le code qui sera retourné chez vous?

Cordialement

Share this post


: post
Share on other sites

Posted · Report post

Bonjour

et encore merci pour votre aide

voici le résultat de votre procédure :

string(31) "www.jl-transferts-numeriques.fr"

string(6) "5.2.17"

string(66) "https://www.butterflive.com/remote/key_info?key=DBFDD40CBCA01F27DA"

object(stdClass)#2 (3) { ["active"]=> bool(true) ["pro"]=> bool(false) ["urls"]=> array(1) { [0]=> string(38) "http://www.jl-transferts-numeriques.fr" } }

j'espère que vous pourrez avoir quelque chose...

cordialement

JL

Share this post


: post
Share on other sites

Posted · Report post

Merci beaucoup Jean Luc, nous avons pu régler le problème de l'affichage grâce à ces informations. Vous devriez voir dans l'interface d'administration un rectangle vert vous informant que votre site est bien activé sur Butterflive.

Passons maintenant au code de tracking que Peel devrait insérer dans votre site. Pouvez vous me dire si dans votre fichier modeles/peel6/bas.php , à la ligne 57 se trouve le code suivant? :

if(is_butterflive_module_active()) {

	echo get_butterflive_tracker();

}

Cordialement

Share this post


: post
Share on other sites

Posted · Report post

Re Re !!

ça marche !!!!! y'a maintenant le rectangle vert qui me dit que tout est ok !!

merci beaucoup !!

maintenant, passons au fichier bas.php du répertoire modèles.

là, je peux vous répondre tout de suite que NON, j'ai pas cette ligne, même sans vérifier !!

en effet, je conserve depuis quelques versions déjà le rép modèles sans le modifier puisque j'ai apporté des modifs dans la mise en page de mon site...

je vais donc mettre le bas.php de la version 6.1 à la place de la version $Id: bas.php 13467 2011-01-06 18:33:58Z gboussin $ que j'ai actuellement, et je vous dis de suite...

UP

C'est bon ! tout est ok maintenant !! ça marche vraiment du feu de dieu !!

merci à toute l'équipe !! PEEL est vraiment phénoménal ! un plaisir de travailler avec vous !!

mille mercis !

cordialement

JL

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping