Problème de feuille de style

8 posts in this topic

Posted · Report post

Bonjour,

J'ai développé un site marchand peel premium 6.1 sur un serveur local. Aujourd'hui, au moment de le mettre en ligne via l'hébergeur Online.net, j'ai constaté que les feuilles de style ne fonctionnaient plus. En gros, je me retrouve avec le contenu de mon site mais sans aucune présentation, sans aucun style. Je n'ai pas la moindre idée de l'origine du problème. Y aurait-il un problème de chemin ? Faut-il changer quelque chose dans un de mes fichiers ?

Merci de votre aide.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour seb42,

Des fichiers manquent surement dans votre boutique, ou alors le chemin n'est pas le bon. Pour vérifier ces informations, je vous conseille d'utiliser des outils qui relève les erreurs 404, et peuvent ainsi aider à comprendre l'origine du problème.

Par exemple, le module Firefox Firebug possède un onglet réseaux, qui relève les erreurs 404 en indiquant l'url du fichier appelé mais inexistant. Il existe un autre module Firefox nommé LiveHTTPHeaders, mais dont la lecture est moins facile que l'outil de Firebug

Après lecture des informations recueillis, vous pouvez soit modifier les liens vers les fichiers, soit placer les fichiers à l'emplacement indiqué par les liens.

Simon.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Simon,

Merci de votre retour !

J'ai suivi votre conseil en utilisant Firebug. Par contre, dans ce cas précis l'onglet "réseaux" ne m'indique rien du tout. Il est activé mais il n'y a aucune information.

Comment expliquer que sur un serveur local comme Wamp mes css apparaissent normalement et qu'un simple basculement en ligne (via Filezilla) sur Online.net les fait disparaître ?

Seb42

Share this post


: post
Share on other sites

Posted · Report post

Pour faire fonctionner l'outil d'analyse de réseaux de firebug, vous devez activer firebug, cliquer sur l'onglet réseaux, vérifier que le panneau réseaux est activé (le message Panneau Réseau activé. Quand le panneau est désactivé, aucune requête n'est affichée. s'affiche).

Rafraichissez ensuite votre page.

Je suis d'accord avec vous, changer de serveur ne devrais pas pouvoir causer ces problèmes, c'est étrange ...

Avez vous un lien vers votre site en ligne à communiquer, pour que je puisse voir d'où peux venir le problème.

Simon.

Share this post


: post
Share on other sites

Posted · Report post

L'outil d'analyse fonctionne maintenant parfaitement et m'indique pas mal d'erreurs du style "302 Found", "404 Not Found" et "500". Je pense que cela peut venir d'un de mes fichiers htaccess.

Il s'agit d'une version test du site sur http://www.place-du-peuple.com/placedupeupletest/

J'espère que vous pourrez m'aider en m'indiquant la bonne marche à suivre pour régler ce problème.

Seb42

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Vous avez placé votre boutique dans un sous dossier de votre hébergement, le répertoire placedupeupletest.

- Dans le .htaccess, vous devez configurer le paramètre RewriteBase pour permettre la prise en compte de ce cas de figure.

À la ligne 96 du fichier, décommenter la ligne en supprimant le caractère #, et modifier la valeur par défaut monrepertoiredeboutique par placedupeupletest.

- Dans le fichier lib/setup/info.inc.php, vous devez renseigner la variable $wwwroot avec cette valeur : http://www.place-du-peuple.com/placedupeupletest/

Simon.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour Simon,

Merci pour votre mail !

Les réglages que vous m'avez préconisés étaient déjà effectifs.

Comme je le craignais il y a problème avec les fichiers "htaccess" de peel shopping...

En enlevant tous les fichiers htaccess, mon style css est enfin revenu et tout semble enfin fonctionner.

Mais cette solution est un peu extrême et pour la sécurité du site je souhaiterais réintégrer les htaccess. Comment faire ?

Y-a-t-il des problèmes de compatibilité entre ces fichiers et l'hébergeur Online.net ? Toujours est-il que cela est très gênant est indépendant de mon action...

Seb42

Share this post


: post
Share on other sites

Posted · Report post

Problème résolu...

Merci Peel

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping