[Résolu] Problème Pour Enregistrer Des Modificactions Dans Les Articles


8 posts in this topic

Posted · Report post

Bonjour,

Je galère depuis plsieurs jours sur un problème qui m'est apparu lorsque je faisais des mises à jour d'articles. Je suis sur la version 6.4.1

Depuis septembre, j'ai un site qui fonctionne (www.sitoran.com) mais bien évidemment en perpétuel évolution. Il est en 3 langues avec une priorité sur l'Espagnol. Je traduit petit à petit la partie administration afin que le service client puisse faire certaines modifications ou ajouts lui-même.

Dernièrement je met en place des catalogues car nous commençons à travailler avec des pays d'Afrique. 

Ces catalogues sont des rubriques (Temas en espagnol) dans lesquels j'ai mis des articles (Articulos en espagnol)

1èrement avant d'avoir le problème de mise à jour des articles, je ne pouvais et ne peux tjrs pas (sauf de temps en temps ça passe mais je ne sais pourquoi) mettre une image avec lien vers un fichier type pdf. Je peux mettre l'image qui se charge bien dans le fichier upload et je peux charger le fichier.pdf dans upload mais celui-ci n'est pas pris en compte. Je ne peux faire accepter á la fin de la saise. Je fais Annuler et je n'ai que l'image avec son lien vers upload/etc.. Je dois entrer en html pour saisir le lien vers le fichier.pdf.

Cela ne permet pas à un utilisateur lambda de saisir un nouveau catalogue.

 

Je finis donc mes saisies en html pour introduirele lien vers le fichier.pdf - Un ami m'a conseille de mettre des noms de fichier sans espace (%20). Il parait que PHP n'aime pas trop. J'ai mis des noms d'image .jpg et fichier .pdf sans espace ie: catalogue_SITORAN.pdf ou lieu de catlogue SITORAN.pdf ==> c'est pareil. Peut-il y avoir un problème de volume du pdf? J'en ai certains qui sont entre 10 et 25 MB pour les plus gros catalogues.

 

Mais à présent j'ai un problème plus sérieux. Je ne peux plus faire de mise à jour d'un article. Tout ce que je saisis est à priorie pris en compte mais en définitive NON.

Si je crée un article nouveau et que je n'oublie rien (tous les liens vers les images et fichiers étant mis directement en html), y compris la petite imagette en bas de la page de saise, l'article est complet et accessible. 

Mais je m'aperçois que j'ai fait une erreur dans un texte et que je souhaite modifier celui-ci, je peux écrire tout ce que je veux mais ce n'est pas pris en compte.

Ce problème m'est survenu alors que je faisais une modification sur un article (je venais de supprimer l'image pour en mettre une autre) et à ce moment j'ai eu un message 

 

 
Internal Server Error 500
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@sitoran.antoniotornero.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
 
Je me suis en contact avec le support du serveur qui héberge le site. Il m'a confirmé qu'au même moment il y avait une mise à jour sur le serveur. Il est donc revenu en arrière. Je n'ai plus l'erreur 500 mais je ne peux tjrs pas mettre à jour les articles et cela se passe uniquement avec les articles.
J'ai supprimé les articles de la rubrique en question, j'ai supprimer la rubrique. J'ai recréer la rubrique et recréer les articles ==> bilan, je ne peux faire de modifications sur les articles. Elles ne sont pas prises en compte. Je reste avec ce qu'il y a déjà inscrit.
Je suis revenu à la version française de articles.php et rubriques.php car je travailais avec une version traduite en espagnol (et ce depuis le début et sans aucun pbm) mais c'est identique. 
Le support du serveur après une semaine de recherche ne voit pas d'où peut venir le pbm.
Je ne sais plus quoi tenter et je souhaiterai l'avis d'un expert pour me guider soit au niveau du programme ou bien me communiquer ce que je dois demander au support du serveur de vérifier.
J'oubliai: si je fais les modifications directement sur la BDD, les modifications sont bien prises en compte. J'ai donc la possibilité de maintenir le site mais c'est à la fois dangereux et je ne peux laisser faire cela à une secrétaire ou pour mieux dire je ne me vois pas expliquer comment entrer dans la BDD pour faire des mises à jour ... 
 
Tout ce laius pour expliquer quelque chose probablement très simple pour vous mais apès une semaine je ne sais plus à quel Saint me vouer.
Je vous remercie par avance pour vos suggestions.
Bien cordialement.
Alain

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

 

Si vous avez des problèmes plus ou moins aléatoire de prise en compte de formulaire avec des uploads à l'intérieur, et d'autant plus si vous avez eu des problèmes d'erreur 500, il s'agit souvent de réglages sur le serveur qui limitent la taille des uploads, ou la taille des variables POST. Ceci peut être lié à Suhosin, ou à d'autres réglages de php.ini.

Vous parlez de fichiers d'au moins 10 Mo parfois, or souvent les serveurs sont par défaut limités à des uploads de quelques Mo.

Tout ça nécessite d'étudier vos logs d'erreurs serveur, et de tester point par point => prévoir 2 à 4h.

 

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Merci Gilles pour ta réponse.

Je vais voir avec le support serveur pour les ajustements auxquels tu fais référence.

Nánmoins, le problème que j'ai actuellement de mise à jour des articles, sans parler de upload, simplement changer un texte qui ne fonctionne pas peut-il être assimilé à "des réglages de php" sachant que ça ne se produit qu'avec les articles. Par contre si je saisis un article (hors upload). je dirai tous les textes dans les trois langues puisque le site fonctionne en 3 langues, si je saisis tout correctement y compris l'image de l'article, tout est correctement pris en compte. C'est seulement quand je veux modifier. Il semble que c'est pris en compte quand je fais sauvegarder mais en fait il n'en est rien. J'ai un problème similaire quand je veux mettre le lien Google pour le plan d'accés.C'est comme si je n'avais rien saisi.

Curieux.

Merci pour tes conseils.

Bien cordialement.

Alain

Share this post


: post
Share on other sites

Posted · Report post

Bosoir Gilles,

Je souhaite te communiquer où j'en suis avec mes problèmes sur la gestion des articles.

J'avais des problèmes suite, semble-t-il à une mise à jour sur le serveur - erreur 500. Néanmoins même après être revenu en arrière au niveau du serveur je n'avais plus l'erreur mais les modifications n'étaient pas prises en compte - notamment je n'avais pas le message indiquant que les modifications avaient prises en compte. Sans solution côté serveur, j'ai réinstallé le script de articles.php d'une première version que j'avais chargé - version 6.4 - à la place de la version que j'utilisais 6.4.1

Résultat positif: je peux faire les mises à jour d'articles et ils sont bien pris en compte.

Par compte suite aux réglages au niveau serveur (taille de fichier à charger, etc..), j'ai toujours le problème lorsque je mets une image avec un lien vers un document .pdf (quelque soit sa taille) le lien n'est pas pris en compte. Je dois rentrer dans le html pour l'inclure.

SVP, n'auriez-vous pas une solution?

Merci d'avance.

 

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

 

Je n'ai jamais eu connaissance de ce genre de problème, et donc je ne peux que te donner des idées à investiguer :

- problème de gestion de type MIME par le serveur, qui ne "connait" pas les PDF

- sécurité quelconque sur le serveur qui empêcherait l'upload

- mauvais paramétrage de PEEL Shopping n'autorisant pas l'upload des PDF (par défaut, c'est bien autorisé)

 

Il est fort possible qu'il faille se pencher sur un cas concret et deboguer avec des var_dump pour comprendre ce qui se passe => 1h de travail pour identifier problème de configuration apache, ou pour résoudre si problème lié à la partie PHP.

 

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Bonsoir Gilles,

Désolé de n'avoir pu te répondre plus tôt.

Pour ce qui est du chargement des pdf (quelque soit la taille) j'ai résolu le problème.

J'explique au cas où quelqu'un aurait ce pbm.

Lorsque je voulais charger une image (page de garde d'un catalogue) je voulais mettre cette image à droite dans le cadre "Texte complet de l'article" ayant cadré du texte à gauche. J'allais chercher l'image sur le serveur (ele avait été chargée précédemment dans upload) et ensuite j'indiquais le lien du pdf également dans upload (chargé avec Filezilla) et ce n'était pas pris en compte.

J'ai procédé de manière différente, à savoir que je charge l'image à gauche dans le cadre  "Texte complet de l'article" et tout se charge correctement y compris charger le pdf dans upload. Ensuite je déplace l'image à droite et j'ajoute le texte que je souhaite mettre en complément. De cette façon, je n'ai plus de problème. Bien évidemment je n'ai pas d'explication mais cela fonctionne, au moins dans mon cas. J'espère avoir été clair dans mon explication et si nécessaire je ne manquerai pas de communiquer plus de détails si cela peut aider.

Je te remercie pour ton assistance et je vais fermer ce sujet.

Bien cordialement.

Alain

Share this post


: post
Share on other sites

Posted · Report post

SVP, comment fait-on pour indiquer que le sujet est "résolu". Je ne retrouve pas la procédure.

Merci.

Bien cordialement.

Alain

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

 

Le plus simple est d'éditer le titre du sujet pour indiquer résolu, chose que je viens de faire.

J'imagine que votre problème était lié à un chemin relatif à la place de chemin absolu pour accéder à votre image.

 

Gilles

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping