Installation Version 7

4 posts in this topic

Posted · Report post

Bonjour,

 

Je suis en train d'installer la version 7 de Peel sur mon site internet. J'ai donc téléchargé le ZIP des fichiers, installé le tout dans un répertoire de mon site /resto/ et configuré le htaccess comme ci dessous :

 

# - Chez OVH, activez les lignes suivantes en retirant le # en début de ligne :
SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0
# et activez aussi plus loin dans le fichier la ligne RewriteBase / ou /monrepertoiredeboutique/

...

# CONFIGURATION : Sur certains hébergements (OVH, Amen, ...) il faut parfois configurer le RewriteBase en retirant le # en début de ligne
# Attention : si vous n'êtes pas à la racine de votre domaine, indiquez /monrepertoiredeboutique/
# RewriteBase /
# ...ou... :
RewriteBase /resto/

 

Puis, une fois le tout installer sur mon répertoire, je lance l'installation avec l'adresse : ..../resto/installation/index.php

 

Et là mon navigateur internet m'indique une Erreur 500 et marque ci-dessous :

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, postmaster@www.xxxxx.fr and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

 

Pouvez vous me dire où j'ai mal fait pour ne pas pouvoir paramètrer la boutique.

Merci par avance pour votre réponse

Share this post


: post
Share on other sites

Posted · Report post

essaie de remettre le fichier tel qu'il était à l'origine

Share this post


: post
Share on other sites

Posted · Report post

Bonjour, je viens d'essayer avec le fichier d'origine et ça me sort :

 

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.313/jlproduc/www/resto/lib/class/String.php on line 33
 

 

et si je ne paramètre uniquement les lignes pour le PHP5, cela me donne le même résultat d'erreur 500.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

 

- Sans SetEnv PHP_VER 5, vous êtes en PHP4, d'où l'erreur que vous avez de parse error.

- avec SetEnv PHP_VER 5 ça doit marcher d'après http://guide.ovh.com/php5chezovh

  => donc soit vous avez utilisé un éditeur de texte qui a vérolé votre fichier => utilisez notepad++ et n'éditez que la ligne SetEnv PHP_VER 5

  => soit vous avez un problème sur votre hébergement pour activer PHP5 => voyez avec OVH

 

Gilles

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping