probleme retour paiement sustempay

3 posts in this topic

Posted · Report post

Bonjour,

j'ai la version premium 7.0.4

je dois faire face à ce message :

Lors de l'appel de votre URL de notification https://www.monsite.fr/modules/systempay/ipn.php, nous avons rencontré un problème technique dont le code d'erreur est : FAILED_SSL_HANDSHAKE_EXCEPTION.

Soit nous n'avons pas pu contacter votre serveur (indisponibilité de votre site marchand), soit votre serveur nous a répondu dans un délai beaucoup trop long, soit votre serveur nous a répondu un message d'erreur. Vous pouvez retrouver le type d'erreur rencontré dans l'historique des évènements de la transaction de votre Back Office marchand.

Le paiement a été finalisé positivement ou négativement par la plateforme de paiement, mais il est possible que votre site marchand ne soit pas à jour. Il est inutile d'appeler le support technique car nous n'avons pas d'action sur votre informatique. 

merci de vos futures réponses.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

C'est que votre serveur et celui de Systempay ne peuvent se mettre d'accord sur le protocole d'encodage du https de votre page. Vérifiez que votre https est bien configuré, et utilisez des outils sur internet du genre "SSL Checker".

Ce sujet est indépendant du code de votre site PHP, il dépend d'apache, et de la configuration générale de votre serveur.

Gilles

Share this post


: post
Share on other sites

Posted · Report post

Je l'ai fait pour vous, voici l'essentiel :

Visit our documentation page for more information, configuration guides, and books. Known issues are documented here.
This server is vulnerable to the POODLE attack against TLS servers. Patching required. Grade set to F. MORE INFO »
This site is intolerant to newer protocol versions, which might cause connection failures.
The server supports only older protocols, but not the current best TLS 1.2. Grade capped to C.  MORE INFO »
This server accepts the RC4 cipher, which is weak. Grade capped to B.  MORE INFO »
The server does not support Forward Secrecy with the reference browsers.  MORE INFO »
 
TLS version intoleranceTLS 1.1  TLS 1.2  TLS 1.3  TLS 1.98  TLS 2.98   PROBLEMATIC


Il y a de fortes chances que l'absence de support de votre serveur de TLS 1.2 voire 1.1 crée le problème que vous avez.

Gilles

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping