Compatibilité PHP 5.2 de la version 8.0

3 posts in this topic

Posted · Report post

je migre de 7.21 à 8.0 en suivant vos indications. Après copie des nouveaux fichiers sur mon hébergement je me connecte en ayant changé le thème en peel7. Voici le mesage d'erreur !

Parse error: syntax error, T_PAAMAYIM_NEKUDOTAYIM inattendu dans /home/lesquats/www/lib/class/Module.php sur la ligne 102

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Vous utilisez manifestement une version de PHP inférieure à 5.3. Je vous invite à mettre à jour votre serveur ou à changer d'hébergement car cette version de PHP a maintenant 5 ans.

Pour que le code soit compatible avec votre version, dans /lib/class/Module.php à la ligne 102, changez     $this::     par     self::

Cette modification sera présente dans la prochaine version du logiciel.

Gilles

Share this post


: post
Share on other sites

Posted (edited) · Report post

Ca ne marche pas self en ligne 102 mais j'ai monté ma version PHP chez ovh avec un .ovhconfig à la racine du site et c'est migré.

Merci.

Edited by louba

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping