erreur URL rubrique

8 posts in this topic

Posted · Report post

Bonjour,

Lors de la création d'une rubrique lorsque je veux accéder à celle-ci j'ai une erreur 404

mon url est http://mondomaine.com/lire/?rubid=1

Où dois-je faire une correction afin de pouvoir accéder à cette rubrique

merci d'avance

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Vérifiez que le répertoire lire/ a bien été transféré en FTP sur votre hébergement. Vérifiez les logs d'erreur de votre site pour savoir ce qu'ils disent au sujet de cette erreur, peut-être que la requête arrive ailleurs que là où vous pensez. Et essayez en rajoutant à la main index.php après lire/ pour voir ce que ça donne, il y a peut-être un problème de configuration de fichier index par défaut sur votre hébergement.

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Effectivement en rajoutant index.php après lire cela fonctionne

je suis chez 1&1

Merci

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Vous pouvez modifier le fichier .htaccess de vote site en ajoutant la règle suivante (au début du fichier par exemple):

DirectoryIndex index.html index.php

Cela permettra le chargement de la page index.php lorsque vous demander le dossier lire/

 

Share this post


: post
Share on other sites

Posted · Report post

j'ai eu ce probleme " aussi 1and1" et simon ma donner la solution 

 

commenter ceci dans le .htaccess

    RewriteEngine on

en

#  RewriteEngine on

pour moi sa a résolu le probleme

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Sur la dernière version de peel  8.0.5 que j'ai téléchargé dans le fichier htaccess il y a cette ligne

# Si lire/ par exemple ne marche pas alors que lire/index.php marche, alors activez :
 DirectoryIndex index.html index.php

J'ai activé le ligne Directory...

mais cela ne fonctionne pas. Aurais-je oublié une manipulation ?

Je suis chez 1&1

merci d'avance de votre aide

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

Ce sujet dépend de la configuration de l'hébergement, je vous invite donc à vous tourner vers le forum d'aide technique de votre hébergeur.

Share this post


: post
Share on other sites

Posted · Report post

bonjour j'ai eu le même problème 

 

et j'ai directement modifier dans : lib -> fonction ->  url_standard.php

if (!function_exists('get_content_category_url')) {
	/**
	 * get_content_category_url()
	 *
	 * @param integer $id
	 * @param mixed $title
	 * @param mixed $rub_id
	 * @param mixed $rub_name
	 * @return
	 */
	function get_content_category_url($id = null, $name = null, $add_get_suffixe = false, $html_encode = false)
	{
		if(!empty($id)) {
			$url_rub = get_url('/lire/', array('rubid' => intval($id)));
			if ($add_get_suffixe) {
				if ($html_encode) {
					$url_rub .= '&';
				} else {
					$url_rub .= '&';
				}
			}
		}else{
			$url_rub = get_url('/lire/');
			if ($add_get_suffixe) {
				$url_rub .= '?';
			}
		}
		return $url_rub;
	}
}

modifier

 get_url('/lire/'

en :  

 get_url('/lire/index.php'

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping