Souloumiac

Utilisateur open source
  • Content count

    48
  • Joined

  • Last visited


Everything posted by Souloumiac

  1. Souloumiac added a post in a topic Affichage dans menu sous-rubrique et/ou article de Niveau 3   

    Bonsoir,
    Je me suis certainement mal exprimé. Je désirais augmenter la profondeur du menu des rubriques.
    J'ai essayé en modifiant la valeur de la variable product_categories_depth_in_menu mais sans succès.
    A partir de votre information, j'ai donc cherché dans les autres variables et j'ai agi sur la variable suivante :
    content_categories_depth_in_menu en mettant comme valeur 2 (elle était à 1 précédemment et
    je pense qu'elle commence à 0).
    Cela a fonctionné.

    Pour faciliter ce genre de modifications, existe t'il un dictionnaire des variables de Peel ? et
    existe t'il un tutoriel de paramétrage de Peel ?
    Ces deux documents donnerait, encore plus, l'envie d'utiliser Peel.
    Merci par avance de votre retour.
    Cordialement.
    Patrick
    • 0
  2. Souloumiac added a topic in PEEL SHOPPING : logiciel open source de boutique en ligne   

    Affichage dans menu sous-rubrique et/ou article de Niveau 3
    Bonjour,
    Je rencontre un souci d'affichage de sous-rubrique et/ou article de Niveau 3.
    J'ai un menu avec une rubrique (Niveau 1 du menu) puis une sous-rubrique (Niveau 2) et enfin une sous-rubrique et/ou article donc de Niveau 3.
    Dans le back-office, pas de soucis, je vois bien mes 3 niveaux avec les décalages à l'écran ainsi que tous mes voyants au vert (en ligne).
    Par contre à l'affichage en ligne, dans le menu concerné, l'affichage s'arrête au niveau 2 !
    J'ai cherché dans le paramétrage du site quelque chose au niveau profondeur d'affichage des menus et j'ai cherché également dans le forum mais sans succès.
    Merci par avance de votre aide précieuse.
    Cordialement.
    Patrick
    • 10 replies
    • 1,364 views
  3. Souloumiac added a topic in PEEL SHOPPING : logiciel open source de boutique en ligne   

    Rubrique avec sous-rubriques - Pas de lien sur la rubrique
    Bonsoir,
    Je vais essayer d'être clair dans mes explications.
    J'ai un menu comportant des rubriques dont certaines avec des sous-rubriques (menu déroulant), je souhaite aucun lien d'ouverture de page suite à un clic sur une rubrique comportant des sous-rubriques.
    En fait, lorsque je survole ou je clique sur une rubrique comportant des sous-rubriques, j'obtiendrai alors uniquement la liste déroulante des sous-rubriques avec leurs liens vers leur page respective.
    Ceci afin de ne pas être dans l'obligation de créer une page 'bidon' pour répondre au clic sur la rubrique comportant des sous-rubriques.
    J'espère avoir été assez clair mais pas facile.
    Toujours dans le cadre de ces menus déroulants de sous-rubriques, en mode nomade (smartphone, tablette...) existe t'il un paramétrage pour lors de l'affichage du menu (suite au clic sur l'icône avec des tirets), l'on puisse afficher les sous rubriques systématiquement sans cliquer sur le petit triangle tête en bas, qui n'est pas toujours facile à cliquer ?
    Merci par avance de vos précieux conseils.
    Patrick
     
    • 2 replies
    • 661 views
  4. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    Après quelques jours d'absence, je viens de tester votre dernière proposition :
    Modification dans le fichier 'display.php' (sous /lib/fonctions/) =>
          $tpl->assign('site_id', $GLOBALS['site_id']);
          Cette ligne est à placer après $GLOBALS['tplEngine']->createTemplate('menu.tpl');
    Modification dans le fichier 'menu.tpl' (sous /modeles/peel7/smarty/) =>
         {if $site_id == 1}
             Votre code HTML pour le site 1
         {else}
             Votre code pour les autres sites
         {/if}
    Cela fonctionne parfaitement, tout aussi bien que ma proposition du 12 septembre.

    Je vais donc pouvoir poursuivre dans l'élaboration de notre site à deux casquettes grâce à votre mode 'multisite'.
    Je tenais à vous remercier pour votre réactivité et pour votre aide, j'ai beaucoup appris et progressé grâce à vous.
    En espérant que tout ceci serve également à d'autres utilisateurs de Peel.
    Patrick
    • 0
  5. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    J'ai continué mes recherches en attendant votre avis.
    Concernant la problématique suivante :
    if ($GLOBALS['site_id'] == 2) {
    la commande spécifique à réaliser pour le site appelé => 1 pour le site principal et 2 pour le site virtuel
    }
    le chiffre changera entre 1 ou 2 selon le site à traiter

    Je me suis aperçu qu'il était impératif de placer cette commande en début du fichier index.php mais APRES la commande :
    include("configuration.inc.php");
    sinon la variable globale [site_id] n'est pas encore connue d'où le non fonctionnement du test if
    Maintenant cela fonctionne

    Pour la problématique suivante :
    {if $GLOBALS['site_id'] == 1}
    <li><a href="http://www.siteprincipal/boutique"> Boutique </a></li>
    {/if}
    Comme je n'arrive pas écrire correctement la syntaxe de la commande (merci de votre aide) dans le fichier particulier menu.tpl, de plus je ne suis pas sûr que la variable [site_id] soit bien accessible par le fichier menu.tpl , bien que cette variable soit globale.
    J'ai donc utilisé cette astuce depuis le fichier display.php :
            if ($GLOBALS['site_id'] == 1) {
            $tpl = $GLOBALS['tplEngine']->createTemplate('menu.tpl');
            }
            if ($GLOBALS['site_id'] == 2) {
            $tpl = $GLOBALS['tplEngine']->createTemplate('menu_site2.tpl');
            }
    Tout ceci en lieu et place de :
    $tpl = $GLOBALS['tplEngine']->createTemplate('menu.tpl');
    et j'ai recopié le fichier menu.tpl dans un fichier renommé menu_site2.tpl, dans l'un j'ai mis ma balise li avec le choix de menu supplémentaire vers la boutique et dans le second la balise li qui pointe vers le retour vers le site principal. Cela fonctionne.
    Merci par avance de votre avis sur tout cela.
    Patrick
     
    • 0
  6. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    Après pas mal de recherche sur le Net et d'essais ce WE, le site en mode multisite de peel.fr s'est mis a fonctionné correctement. Le site 'boutique' a bien été cherché
    - le fichier css spécifique et déclaré dans la configuration du site virtuel 'boutique',
    - les emplacements de module (ex le panier) déclaré à l'affichage pour le site virtuel 'boutique',
    - les catégories de produits & produits déclarés pour le site virtuel 'boutique',
    - le rédactionnel attribué au site virtuel 'boutique'.
    L'élément déclencheur a été la création d'un sous répertoire vide boutique sous la racine du site principal. J'en ai déduit que chez OVH, il faut ce répertoire même si c'est l'index.php appelé sur la racine du site principal qui gère le site principal ainsi que le site virtuel. L'essentiel est que cela fonctionne correctement. (et cela sans modifications de vos commandes indiquées pour le htaccess et le configuration.inc.php reprises dans nos échanges ci-dessus. Encore merci à vous)
    Maintenant, je vais réaliser les spécificités de chacun des sites via le mode administrateur et via la commande que vous m'avez indiqué ci-dessus soit :
    if ($GLOBALS['site_id'] == 2) {
    la commande spécifique à réaliser pour le site appelé => 1 pour le site principal et 2 pour le site virtuel
    }
    le chiffre changera entre 1 ou 2 selon le site à traiter
    J'ai donc fait des essais mais sans succès :
    Tout d'abord dans le fichier index.php =>
    if ($GLOBALS['site_id'] == 2) {
    echo '<script language="javascript">';
    echo 'alert("site numéro 2")';
    echo '</script>';
    die('site numéro 2');
    }
    Rien ne se passe, comme ci la variable globale 'site_id' n'était pas reconnue. Pour information, sans le if, les commandes alert et die fonctionnent parfaitement.
    D'autre part, dans les variables de configuration du mode administration, je n'ai pas trouvé la variable 'site_id' mais c'est peut être normal.
    D'autre part, j'aurais voulu un choix de menu spécifique que pour le site principal, j'ai donc ajouté le test if à la commande li ajoutée au fichier menu.tpl (balise li ajoutée selon vos conseils), et là je me ramasse un message d'erreur.
    {if $GLOBALS['site_id'] == 1}
    <li><a href="http://www.siteprincipal/boutique"> Boutique </a></li>
    {/if}
    Pour info, sans la commande if, le choix s'affiche et fonctionne parfaitement dans le site principal et dans le site virtuel boutique (Normal mais pas le but)
    Merci par avance de vos conseils.
    Patrick
     
    • 0
  7. Souloumiac added a post in a topic FCKeditor et Chrome et Firefox Mozilla   

    Bonjour,
    Pour information, j'ai remplacé le fichier fckeditor.php sous lib/FCKeditor par le fichier fckeditor_php5.php disponible sous ce même répertoire, bien évidemment en le renommant ensuite en fckeditor.php.
    Pour le moment, cela fonctionne parfaitement avec Chrome.
    Ceci solutionne, certainement provisoirement, le problème rencontré du fait que le PHP va continuer d'évoluer ainsi que Chrome mais par contre fckeditor n'est plus suivi!
    Ensuite, la solution serait d'utiliser, probablement, ckeditor par exemple comme indiqué par Simon, je n'ai pas encore regardé comment implanter l'onglet 'téléchargement' dans le module d'insertion d'image, très pratique sous fckeditor, apparemment il faudrait installer un plugin. Ou alors tinymce (voir ci-dessus les propositions de Simon).
    Donc à suivre.
    Patrick
    • 0
  8. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    Par rapport à mon interrogation précédente, peut être dois je ouvrir un nouveau sujet ?
    Merci par avance de votre réponse.
    Patrick
       Citer
    • 0
  9. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    Je vous remercie pour votre réponse.
    Effectivement, j'aurais dû relire le code proposé le 06/09/16 avant son utilisation par un copier/coller, j'ai donc réalisé la correction de l'espace mais sans succès.
    J'ai consulté OVH, qui est maintenant notre hébergeur puisque le précédent était incompatible avec peel.fr et qu'OVH est donné compatible d'où notre migration (coût) : la première opération est de vérifier la présence de l'instruction suivante : RewriteEngine on   dans le htaccess. J'ai donc vérifié immédiatement, et là j'ai découvert ce commentaire :
    # Toute la section des Rewrite[...] ne fonctionnera que si l'hébergement ne supporte pas l'URL Rewriting
    # Pour avoir PEEL Shopping utilisant l'URL Rewriting, vous devez installer le module Premium
    Cela veut-il dire que le multisite ne fonctionnera jamais avec la version non Premium, si oui, nous avons donc passé beaucoup de temps, vous et moi, pour rien alors ? et je serai alors très déçu.
    Dans l'attente de vous lire.
    Patrick
    • 0
  10. Souloumiac added a topic in PEEL SHOPPING : logiciel open source de boutique en ligne   

    FCKeditor et Chrome et Firefox Mozilla
    Bonsoir,
    Je viens de constater un souci entre FCKeditor et Chrome. Pour information, je suis sous Windows 10.
    En effet, lorsque je suis dans le mode administrateur de Peel sous Chrome (Version 52.0.2743.116 m), le contenu de la section de l'éditeur FCKeditor est vide avec impossibilité d'y accéder ! alors que cette section comporte des informations.
    Pour information, cela fonctionne parfaitement avec Firefox Mozilla (Version 45.0.1).
    Mon réflexe a été de changer d'éditeur pour utiliser par exemple CKeditor, avec celui-ci cela fonctionne parfaitement sous Chrome et Firefox Mozilla.
    Mais le souci est que l'éditeur FCKeditor est plus pratique pour l'insertion des images car il donne accès au téléchargement des images et du coup facilite l'insertion d'images.
    Que dois je paramétrer pour obtenir la compatibilité de FCKeditor avec Chrome.
    Merci par avance.
    Patrick
     
    • 2 replies
    • 702 views
  11. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    Pour l'ajout du point supplémentaire dans le menu à partir d'un ajout dans le fichier menu.tpl avec une balise li, cela fonctionne sans soucis. Merci.
    Par contre désolé, mais une fois de plus l'accès à la page du 2e site reste inaccessible, j'ai effectué tout ce que vous m'avez indiqué :
    - RewriteRule boutique/(.*) /$1 [QSA,L] dans le htaccess sous la racine du site principal
    - ajout de ce code à l'endroit spécifié dans le fichier configuration.inc.php sous la racine du site principal :
    if (strpos($_SERVER["REQUEST_URI"], '/boutique /') !==false) {
        $GLOBALS['wwwroot'] = $GLOBALS['wwwroot'].'/boutique';
    }
    Et là j'ai toujours l'erreur suivante : La page demandée n'est pas disponible
    Pour info, j'ai enlevé puis ajouté le test ci-dessous au début du fichier index.php sous la racine du site principal, mais rien ne change :
    if ($GLOBALS['site_id'] == 2) {
    die('site numéro 2');
    }
    Je sens que l'on n'est plus très loin, c'est rageant, mais il manque encore un petit quelque chose pour y arriver et clore ce point.
    Que puis je faire comme essais ou tests pour vous aider à solutionner ce soucis.
    Merci par avance.
    Patrick
     
     
    • 0
  12. Souloumiac added a post in a topic Couleur du menu et sous menu   

    Bonjour,
    Super, merci pour votre réactivité et votre aide.
    Bonne journée.
    Patrick
    • 0
  13. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonjour,
    Voici le résultat de mes essais suite à votre réponse réactive.
    Point numéro 1 => C'est OK avec votre explication. Merci. Ce point est réglé.
    Point numéro 2 :
    j'ai placé ce code en tout début (juste après les commentaires) de mon fichier index.php de la racine du site :
    if ($GLOBALS['site_id'] == 2) {
    die('boutique');
    }
    J'ai placé dans le htaccess de la racine (pour info, j'ai supprimé RewriteBase / qui semble sans effet) :
    RewriteRule boutique/(.*) /$1 [QSA,L]
    j'obtiens ce message d'erreur => La page demandée n'est pas disponible
    J'ai donc enlevé le fameux / derrière boutique dans le htaccess (comme lors de mes essais d'hier), dans ce cas, je n'ai plus le message d'erreur mais je ne charge toujours pas la page 'boutique' (pour info l'URL dans le navigateur est alors : www.monsiteprincipal/boutique)
    J'ai fait les essais également avec ceci dans l'index.php (mais je pense qu'il fallait bien que je remplace 'site numéro 2' par 'boutique', j'ai même faite un essai avec boutique sans apostrophes)
    if ($GLOBALS['site_id'] == 2) {
    die('site numéro 2');
    }  
    Les résultats sont identiques aux essais précédents dont l'incidence du / après boutique dans htaccess et toujours pas le chargement de la page 'boutique'.
    Vous ne n'avez pas répondu sur ce point, mais je pense que cela viendra ensuite :
    Dans la version qui va fonctionner très prochainement avec votre aide, j'en suis persuadé, je désirais, dans le menu, avoir un choix direct vers http:/monsiteprincipal/boutique. J'ai essayé d'utiliser le rédactionnel sans succès car le lien hypertexte est systématiquement placée dans la page appelée par le rédactionnel (rubrique) et non directement au niveau de la commande du menu.
    Dans l'attente de vous lire.
    Patrick
    06/09/16
    Re-bonjour,
    J'ai recherché des informations sur la commande die(); de PHP que je ne connaissais pas et j'ai trouvé ceci :
    La fonction die
    die est un alias de exit : c'est une fonction native de PHP qui permet de stopper l'exécution du script. Si une chaîne de caractères est passée en argument, elle est affichée avant l'arrêt. Si un entier est passé en argument, il peut être utilisé comme statut de sortie (0 signifiant que le programme s'est terminé avec succès).
    Je confirme donc les résultats repris ci-dessus sans affichage à l'écran de boutique ou de site numéro 2.
    Dans l'attente de vous lire.
    Patrick
    • 0
  14. Souloumiac added a post in a topic Couleur du menu et sous menu   

    Bonjour,
    Ok pour vos réponses, cela m'a permis de comprendre, probablement qu'en partie, le fonctionnement du mode responsive.
    Je cherche depuis un moment (actions sur les paramètres dans screen.css) en s'aidant de l'inspecteur' (F12 de Chrome suivant vos conseils) pour blanchir le fond du bouton d'accès au menu (actuellement transparent), le bouton avec 3 barres horizontales. Vous m'aviez donné l'astuce pour modifier la couleur des barres (confirmer par l'inspecteur) mais là je souhaite mettre à FFFFF le fond du bouton comme le panier ou l'accès au compte. Et là je suis dans une impasse :-(
    Merci par avance de vos précieux conseils.
    Patrick
    • 0
  15. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir, 
    Comme d'habitude j'ai beaucoup appris avec vos réponses. Merci.
    J'ai compris que le site virtuel était appelé via le lien placé dans la création du site virtuel (ex. http:/monsiteprincipal/boutique), lors de l'appel de ce lien, le code exécuté intègre alors les paramètres du 2e site en terme de rubriques, articles, produits... modules, gestion des modules sur le site...
    De ce fait, j'ai créé un 2e site à partir de l'administration avec comme 'URL du site*' => http:/monsiteprincipal/boutique avec les caractéristiques identiques au site principal (paramètres par défaut) sauf le fichier css et le non souhait d'affichage du caddie, cela pour essais. De plus, j'ai placé RewriteRule boutique(.*) /$1 [QSA,L] dans htaccess de la racine du site au début de la zone <IfModule mod_rewrite.c> juste après les commentaires (lignes commençant par #).
    J'ai créé des rubriques avec pour cible le site de la boutique.
    J'ai compris également que si je veux faire des opérations PHP particulières sur le 2e site virtuel (id=2 récupéré dans l'administration) il faudra que j’intègre le bout de programme suivant :
    if ($GLOBALS['site_id'] == 2) {
    // Code spécifique à votre boutique
    }
    Comme indiqué précédemment, ce samedi, j'ai vendu au conseil d'administration la boutique en 2e site virtuel donc je n'ai plus le choix maintenant. C'est comme le jour où j'ai imposé peel.fr, mais alors incompatible avec l'hébergeur d'origine d'où le passage chez OVH depuis.
    Tout irait bien sauf ces quelques soucis rencontrés :
    - pour rappel, nous sommes maintenant chez OVH
    1) lorsque je me connecte à l'administration de peel, seul le site principal s'affiche dans 'configuration puis Paramètre du site', le 2e site n'apparaît pas alors qu'il est bien créé!!! Lors de l'ajout d'un nouveau site s'affiche alors dans la liste : le site principal, le site de la boutique (2e site) précédemment non affiché!!! ainsi que le site que je viens d'ajouter d'où en 3e. Ensuite, je supprime donc ce 3e site. Ce n'est pas pratique du tout pour afficher dans la liste le 2e site créé.
    2) lorsque je place dans l'URL de mon navigateur (Chrome ou Mozilla Firefox) http:/monsiteprincipal/boutique, c'est la page d'index de mon site principal qui s'affiche!!! sans intégrer les paramètres du 2e site soit un menu différent au niveau des rubriques, un css différent au niveau des couleurs et pas l'affichage souhaité du caddie (tout cela pour essais et voir si l'on vient bien chercher les paramètres du second site)
    Pour info, ce dysfonctionnement est constaté que le 2e site soit visible ou non dans la liste des sites (voir le point 1 ci-dessus)

    Avant de vous solliciter à nouveau (dérangement), j'ai cherché dans le forum, j'ai passé beaucoup de temps à faire des essais mais sans résultats.
    Du fait de mes recherches dans le forum, j'ai essayé également de mettre dans htaccess : RewriteBase / ou RewriteBase /boutique/ avant RewriteRule boutique(.*) /$1 [QSA,L]. J'ai également supprimé ou ajouté le caractère / dans RewriteRule boutique(.*) /$1 [QSA,L] selon certaines informations dans le forum.
    Dans la version qui va fonctionner très prochainement avec votre aide, j'en suis persuadé, je désirais, dans le menu, avoir un choix direct vers http:/monsiteprincipal/boutique. J'ai essayé d'utiliser le rédactionnel sans succès car le lien hypertexte est systématiquement placée dans la page appelée par le rédactionnel (rubrique) et non directement au niveau de la commande du menu.
    Merci une fois de plus de votre aide, et je suis sûr que nos échanges serviront à d'autres qui consulteront ce forum.
    Patrick
    • 0
  16. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonsoir,
    Désolé pour le petit retard afin de vous donner des nouvelles de mon avancement, mais j'étais en déplacement.
    Voici où j'en suis :
    - j'ai créé un sous répertoire portant le nom de 'boutique" soit http;/www.nom_du_site/boutique
    - j'ai créé un second site dans peel via l'administration avec pour paramétrage de l'URL du site : http;/www.nom_du_site/boutique. Pour les autres paramétrages du site 'boutique', j'ai pompé ceux du premier site soit du site http;/www.nom_du_site (sauf pour le fichier css, car j'ai créé un spécifique pour essai)
    - dans .htaccess de la racine du site j'ai placé, selon vos conseils, à la ligne 185 : RewriteRule boutique/(.*) /$1 [QSA,L] 
    - je suis arrivé à créer une rubrique spécifique pour le site de la boutique, et cela en sélectionnant le site de la boutique dans la liste de choix
    Mais là, où il me manque quelque chose (je suis nul probablement), que dois je mettre comme fichier d'appel dans le répertoire 'boutique' pour atteindre les fichiers spécifiques à la boutique soit le css indiqué dans la configuration du site, les rubriques créées pour ce site 'boutique' et autres éléments (articles) dédiés à ce site.
    Pour essai, j'ai recopié le fichier index.php de la racine dans le répertoire 'boutique', mais je me retrouve comme dans le site principal !!!
    Au fait, pourrai-je avoir un fichier display.php spécifique pour mon site 'boutique' afin de faire certaines modifications dont dans l'entête et le pied  ?
    En définitif, je n'ai pas pigé la liaison entre le paramétrage spécifique dans le mode administration de peel et son application pour le site 'boutique'.
    Sincèrement désolé.
    Et encore merci de votre aide, pour info, j'ai une présentation du site ce samedi, je crois, en l'état des choses, que je parlerai du site 'boutique' qu'en virtuel malheureusement.
    Patrick
    • 0
  17. Souloumiac added a post in a topic Catégorie (Produits) après le rédactionnel   

    Bonjour,
    Je vous remercie pour vos éléments de réponse toujours aussi efficaces.
    Concernant le second point de mon interrogation, je pense que mon explication n'est pas très claire d'où une incompréhension de mon besoin par vous.
    Mon idée est la suivante : sur le même site (même url de base) où se trouve peel.fr, je désire avoir mon site 'principal' composé d’éléments rédactionnels (en profitant de la puissance de peel.fr) mais sans les conditions de vente + panier. Puis à partir d'un lien dans le menu de ce site 'principal' j'arriverais vers une page, mais cette fois purement boutique (avec la puissance de peel.fr soit catégories + produits) avec conditions de vente + panier. Soit 2 facettes de notre société.
    Donc, dans ce but, j'ai installé peel.fr sur la racine www pour le site 'principal' puis une autre installation de peel.fr sous www/boutique/. Cela devait me permettre de gérer mes deux visages de la société, sauf qu'à l'installation, je pensais pouvoir modifier l'index des tables de peel.fr en peel2_ par exemple afin d'être dans la même base de données (sous utilisée en terme de capacité). Et bien non, cette option n'est pas proposée. Mais peut être qu'à partir d'une modification dans le fichier d'installation cette possibilité deviendrait possible ? A moins d'une autre idée de votre part pour traiter ma problématique. Pour info, j'ai déjà vu ce cas d'utilisation sur différents sites sous wordpress, mais je désire rester chez peel.fr pour sa puissance.
    Merci une nouvelle fois pour vos précieux conseils.
    Patrick
     
    • 0
  18. Souloumiac added a topic in PEEL SHOPPING : logiciel open source de boutique en ligne   

    Catégorie (Produits) après le rédactionnel
    Bonsoir,
    Je viens de paramétrer mon site, et je désire mettre sur la droite du menu les catégories (produits) donc à droite du rédactionnel (Rubriques-Articles).
    En effet, je désire mettre en avant la société (son rôle, son histoire, ses réalisations...) donc sur la gauche du menu (proche de la petite maison (accueil) du menu) et seulement ensuite les produits à vendre en dernier à droite du menu horizontal ou en bas du menu vertical.
    J'ai tout de suite voulu utiliser l'information 'Position' qui fonctionne très bien pour l'ordre interne dans le rédactionnel mais qui apparemment ne fonctionne pas entre catégories et rédactionnel. Je n'arrive donc pas à pousser vers la droite les catégories (produits).
    En complément, si je désire renvoyer la vente de produits vers un site secondaire sous la même racine du site (autre solution). Sur ce dernier 'sous site', l'on trouverait alors uniquement les produits en vente, la gestion de compte client ainsi que le panier, dans ce cas faut-il tout réinstaller une version peel.fr sous un répertoire spécifique de mon site ainsi qu'une nouvelle base de données (pour info, j'en possède q'une chez mon hébergeur) ?
    Merci par avance de vos précieux conseils car c'est un des derniers points bloquants que je rencontre avant la mise en service.
    Patrick
    • 28 replies
    • 2,421 views
  19. Souloumiac added a post in a topic Couleur du menu et sous menu   

    Bonjour Simon,
    Tout d'abord merci pour ces informations et félicitations pour votre réactivité.
    Par contre, j'ai bien un fonctionnement correct et attendu sur l'ordinateur et le nomade pour la coloration des petits triangles, la couleur de fond des choix des sous-menus (Merci à vous), mais par contre, pour la couleur de la typo des sous-menus, cela fonctionne que sur l'ordinateur en plein écran, aucune incidence du code de couleur du texte des sous-menus souhaité sur l'appareil nomade ou sur l'ordinateur en réduisant la fenêtre !
    Étrange et bizarre !!!
    J'ai utilisé l'inspecteur de Chrome, très utile, merci pour l'astuce, le style appliqué aux choix des sous-menus semble le bon mais n'est pas mis en application au niveau de la couleur en mode nomade ou sur l'ordinateur avec une fenêtre réduite.
    Voici ce que donne l'inspecteur :
    .dropdown-menu > li > a { white-space: normal; background-color: #FFF; font-weight: 600; color: #00F;} et voici le code correspondant dans le screen.css :.dropdown-menu > li > a {
        white-space: normal;
        background-color :#FFFFFF;   /* Org inexistant  Couleur du fond des choix des sous-menus */
        font-weight: 600; /* Org inexistant valeur du Gras (bold =700) du menu au repos */
        color:#0000FF;  /* Org inexistant  Couleur du texte des choix des sous-menus ATTENTION : fonctionne que sous ordi!!! */
    }Apparemment l'ordre de la couleur souhaitée semble perturbé par le menu déroulant en mode nomade ou en mode ordinateur mais avec une fenêtre réduite. Peut être un ordre issu du bootstrap.css!!!
    Encore merci par avance pour votre aide.
    Patrick
    • 0
  20. Souloumiac added a topic in PEEL SHOPPING : logiciel open source de boutique en ligne   

    Couleur du menu et sous menu
    Bonjour,
    Je viens de paramétrer les couleurs quasi à 80% de mon site et cela en intervenant dans le fichier screen.css (merci à peel.fr pour l'open source de leur application).
    Les modifications qui me restent sont suite au choix de ma couleur de fond de mon menu et de la partie haute du site, ces modifications sont donc nécessaires pour augmenter la visibilité des informations du menu.
    Il me me reste 3 points pour lesquels cela fait des heures que je plante (Grummm!) :
    - je n'arrive pas à modifier la couleur du petit triangle à coté d'un choix du menu (Version ordi et nomade (smartphone,tablette...))
    - je n'arrive pas à modifier la couleur des choix des sous menus (impact surtout en version nomade)
    - je n'arrive pas à modifier la couleur des barres dans le petit carré permettant d'accéder au menu en mode nomade bien évidemment
    J'ai essayé en utilisant le code couleur décodé à l'écran mais mes actions dans le css sont soit sans effet ou soit je ne retrouve pas le code couleur décodé dans le css pour intervenir dessus.
    Merci par avance de votre aide.
    Bonne journée.
    • 6 replies
    • 1,008 views
  21. Souloumiac added a post in a topic OPcache API   

    Bonsoir,
    Suite à vos conseils, j'ai donc contacté mon hébergeur planet-work.
    Je vous adresse ci-dessous leur réponse :
    Votre smarty est configuré pour utiliser Zend Opcache pour garder les templates compilés en cache. Or, sur notre plate-forme, le cache Zend est utilisé pour le bytecode et ne peut être utilisé par les sites des clients. Une solution efficace serait d'utiliser le cache local (filesystem), ou mieux, Redis. Cordialement, Frédéric.De ce fait, j'ai recherché dans les paramétrages de l'application de peel sans succès par rapport à la solution proposée par planet-work.
    Merci par avance de vos précieux conseils, car je me retrouve dans une impasse et j'ai promis de mettre en oeuvre la solution peel (car reconnue en possibilités, efficacité, paramétrage et rapidité d’exécution) et non une autre dans un délai très court. Pour info ; planet-work est également imposé.
    Dans l'attente de vous lire.
    Patrick
    • 0
  22. Souloumiac added a post in a topic OPcache API   

    Bonsoir,
    Merci pour cette réponse et félicitations pour votre réactivité.
    Je vais donc investiguer auprès de mon hébergeur.
    Patrick.
    • 0
  23. Souloumiac added a topic in PEEL SHOPPING : logiciel open source de boutique en ligne   

    OPcache API
    Bonsoir,
    J'ai installé la version peel-shopping_8_0_3 sur un serveur de planet-work.com, l'installation s'est bien déroulée.
    Sauf qu'à chaque page consultée du site installé, j'ai ce message :
    Warning: Zend OPcache API is restricted by "restrict_api" configuration directive 
    in /home/lwempcib/www/lib/templateEngines/smarty/sysplugins/smarty_template_compiled.php on line 169
    J'ai recherché dans votre forum sans succès, et je ne vois pas quelle configuration dois-je effectuer pour éviter ce warning désagréable.
    Pour info, le résultat de version.php : 5.4.45-0+deb7u2 
    Merci par avance de vos précieux conseils.
    • 3 replies
    • 867 views

Twitter Advisto ecommerce

Facebook PEEL Shopping