J1P

Utilisateur open source
  • Compteur de contenus

    141
  • Inscrit(e) le

  • Dernière visite


Réputation sur la communauté

19 Good

À propos de J1P

  • Rang
    Maître ecommerce

Activité de J1P

  1. J1P a ajouté un message dans un sujet  Probleme de devise   

    Bonjour Simon
    J'ai trouve le probleme
    Sur la page fonctions.php il y avait une reference pas defaut l'euro (cf photo)
    J'ai modifie cette devise et maintenant ca fonctionne
    Merci Simon

    • 0
  2. J1P a ajouté un message dans un sujet  Probleme de devise   

    Bonjour,
    Non c'est une creation puis j'ai supprime les devis usd, eur, jpy, ...
    Je vais essayer de recreer avec un site vide pour voir si le probleme est le meme car je ne trouve pas de solutions
    • 0
  3. J1P a ajouté un message dans un sujet  Probleme de devise   

    Bonjour Simon,
    malgre tous ces bons conseils et de nombreux tests, je n'arrive pas a trouver d'ou peut provenir cet euro, n'y a t'il pas 1 endroit dans le code ou il y a une reference a l'euro du style devise par defaut dans le code source ? (autre que l'option choisir la devise par defaut)
    Car dans l'email de confirmation le montant + devise est bon
    Cet euro apparait juste dans achat/historique_commandes.php et fin de commande, je ne comprends pas.
    Je continues mes tests, si vous avez des idees, je suis preneuse, merci Simon
    Je viens de penser a 1 truc, a l'installation j'ai choisi la boutique pre-remplie et non vide, est-ce que cela pourrait venir de la ?
    • 0
  4. J1P a ajouté un message dans un sujet  Probleme de devise   

    Bonjour
    La devise en BDD est VND (cf photo) et cote facture EUR, le montant par contre est bon car la devise VND est a 1 et c'est la seule que j'ai


    • 0
  5. J1P a ajouté un sujet dans Module PEEL Premium pour PEEL SHOPPING   

    Probleme de devise
    Bonjour Simon
    Je rencontre un probleme sur la version 9, j'ai defini une seule devise dans l'admin qui est le VND.
    Lorsque je teste et passe commande j'ai bien la devise VND qui apparait sur toutes les pages, dans le caddie sur la page achat/caddie_affichage.php et jusqu'a achat/achat_maintenant.php hors quand je valide sur cette page et donc que j'arrive sur la page achat/fin_commande.php la devise est modifiee en euro (qui n'est pas presente dans ma liste de devise par ailleur).
    De ce fait lorsqu'on regarde le suivi des commandes aussi bien cote client que dans l'admin on a la devise euro qui apparait.
    Une idee comment corriger ce probleme ?
    J'ai vide mes caches et fait des tests a partir de plusieurs browsers, de plus je n'ai defini qu'une seule devise sur le site.
    En regardant resume_commande.tpl on s'apercoit bien que {$order_amount} reprend le montant de la commande incluant la devise hors je ne comprends pas pourquoi ce changement surtout sur une devise qui n'est pas disponible sur le site. Une idee Simon ?
     
    • 7 réponses
    • 178 vues
  6. J1P a ajouté un message dans un sujet  Formulaire enregistrement   

    Merci beaucoup Simon cela fonctionne, je suis tres contente
    Merci pour votre soutien et de me supporter :)
    • 0
  7. J1P a ajouté un message dans un sujet  Formulaire enregistrement   

    Bonjour Simon,
    Non je pense qu'il y a autre chose a modifier, lorsque je fais des tests d'inscription d'un nouveau client malgre le fait que la fonction send_mail_for_account_creation soit en commentaire, cela ne change en rien le process.
    Le status du client est a 0 c'est a dire qu'il ne peut pas se connecter sans avoir a valider le lien dans l'email.
    J'ai cherche ou etait la valeur 0 de l'user profile "util" mais je n'ai pour l'instant pas trouve. Mon but etant simplement d'accepter toute inscription sans avoir a valider via un lien par mail pour pouvoir commander directement en ligne.
    • 0
  8. J1P a ajouté un message dans un sujet  Formulaire enregistrement   

    Bonjour Simon,
    Oui j'avais bien compris :) neanmoins ma question etait que malgre la mise en commentaire de la fonction, on a toujours un envoi d'email (voir capture) ainsi je supposais qu'il y avait peut etre autre chose a retirer ailleur.
    Une idee ?
     
     

    • 0
  9. J1P a ajouté un message dans un sujet  Formulaire enregistrement   

    Bonjour Simon,
    Je ne comprends pas tres bien pour empecher l'envoi d'email
    La modification doit elle se faire sur utilisateurs/enregistrement.php ? en ligne 214 ?
     
    $id_utilisateur = insere_utilisateur($frm, false, !empty($GLOBALS['site_parameters']['user_register_send_password_by_email']), true);
            if (empty($GLOBALS['site_parameters']['user_double_optin_registration_disable'])) {
                // on récupère les informations sur l'utilisateur qui vient d'être enregistré en BDD pour pouvoir créer le hash qui sécurisera la validation du compte
                $sql = "SELECT *
                    FROM peel_utilisateurs
                    WHERE id_utilisateur = '" . nohtml_real_escape_string($id_utilisateur)."'";
                $query = query($sql);
                $result = fetch_assoc($query);
     
    sur la version 6.2 nous avions directement un echo get_user_register_success($frm); donc c'est pour cela que je suis un peu perdu
    Un petit coup de main sur cela ?
    Merci
    Anh
     
     
    • 0
  10. J1P a ajouté un sujet dans Module PEEL Premium pour PEEL SHOPPING   

    Formulaire enregistrement
    Bonjour Simon,
    Je suis sur la nouvelle version 9 et forcement entre la 6.2 et la 9 tout est bien different.
    J'ai donc lu les anciens messages du forum mais je ne trouve pas les solutions.
    Par exemple sur le formulaire d'enregistrement (inscription), je souhaiterai enlever beaucoup de champs avec etoiles.
    Simon vous disiez de regarder dans administer/configuration user_mandatory_fields mais sur la version 9 il n'y a pas donc j'imagine que ca a du migrer ailleur.
    Ou puis-je enlever les obligations de champs? la mise en page de la page se trouve sur user_register_form.tpl et sur utilisateurs/enregistrement.php il y a bien user_mandatory_fields mais cela ne semble pas affecter les obligations.
    Le formulaire envoie un message de confirmation au client, ou peut-on enlever cette option car les messages n'arrivent pas toujours ou vont dans les spams.
    Merci
    • 8 réponses
    • 239 vues
  11. J1P a ajouté un message dans un sujet  Tableau des attributs   

    Merci Simon, effectivement ce n'est pas la que je l'aurai cherche :)
     
    • 0
  12. J1P a ajouté un sujet dans PEEL SHOPPING : logiciel open source de boutique en ligne   

    Tableau des attributs
    Bonjour
    Je voudrais changer la presentation des attributs en checkbox.
    Sur critere_stock.tpl il y a bien la configuration de Size et Color mais pas des attributs.
    A quel endroit puis-je trouver le <td class="attribut-cell"> pour modifier le tableau des attributs afin de ne pas avoir 2 colonnes.
    En effet lorsque le titre de l'attribut est long, la colonne des checkboxes est trop petite.
    Merci d'avance
    Je suis sur la derniere version 9
    • 2 réponses
    • 340 vues
  13. J1P a ajouté un message dans un sujet  Meta facebook image   

    Bonjour Gilles, je reviens sur ce sujet car je n'ai pas trouve la solution pour le moment. J'ai suivi votre conseil, je comprends que dans la partie meta $product_images n'est pas défini. Vous dites d'utiliser la methode get_product_main_picture().
    J'ai trouve sur display_product
    if (!function_exists('get_product_in_container_html')) {
    function get_product_in_container_html(&$product_object, $only_show_products_with_picture = true)
        {
            $output = '';
            if (!empty($product_object->id) && !empty($product_object->etat)) {
                $urlprod = $product_object->get_product_url();
                $display_picture = $product_object->get_product_main_picture();
     
    par contre je ne comprends pas comment appliquer cela entre mes balises meta
    <meta property="og:title" content="' . trim(strip_tags(String::html_entity_decode_if_needed(str_replace(array("\r", "\n"), '', $m['meta_titre'])))) . '" />
    <meta property="og:description" content="' . $meta_desc . '" />
    <meta property="og:image" content="' . $GLOBALS['repertoire_upload'] . '/' . $product_images[1] . '" />
    Un petit coup de main s'il vous plait
    Merci beaucoup
    Anh
    • 0
  14. J1P a ajouté un message dans un sujet  Moteur de recherche utilisateurs   

    Bonjour Simon, comme pour le profil Demo en réalité
     
    • 0
  15. J1P a ajouté un message dans un sujet  Moteur de recherche utilisateurs   

    Bonjour,
    une autre petite question sur ce moteur de recherche dans l'admin (je suis sous version 6.2), si on veut faire une recherche globale sur tous les utilisateurs, on ne selectionne aucun profil mais l'admin apparait dans ce listing, peut-on ne pas faire apparaitre l'admin dans ce listing ? Mon but etant de donner l'acces a des redacteurs qui peuvent chercher n'importe quel utilisateur mais ils ne devraient pas pouvoir voir ou modifier les admin.
    Merci de votre soutien
    • 0

Twitter Advisto ecommerce

Facebook PEEL Shopping