Ne pas afficher les produits dans les catégorie parent

4 posts in this topic

Posted · Report post

Bonjour, Je suis actuellement encore en version 7.2.0 et j'avais a l'époque l'affichage des produit uniquement dans leur catégorie donc si je met un produit dans la catégorie pantalon et que celle-ci se trouve dans la catégorie vetement, quand j'ouvre vetement il me liste les catégorie fille donc ici "pantalon" et c'est tout et ensuite je retrouve mon produit dans la catégorie pantalon.

Maintenant je retrouve dans ma catégorie vetement tous les produits qui sont dans les sous catégorie... alors que je ne souhaite afficher que les sous catégorie si il y en a sinon les produits.

Une idée? J'ai fait le tour de mes variable, j'ai rien trouver, j'ai fouiller dans le code pour voir si j'avais changer quelque chose mais il me semble pas...

J'ai toucher a quelques petites choses dans l'affichage des articles mais pas des produits, se serai lier?

Merci

Share this post


: post
Share on other sites

Posted · Report post

re, Je suis arriver a avoir se que je souhaite mais je sais pas si c'etait la plus belle façon...

dans products_list_brief.tpl tout en bas j'ai changer ceci:

{if isset($subcategories)}
	<div class="clearfix"></div>
	{$subcategories}
{/if}


{$associated_products}

Par ceci:

{if isset($subcategories)}
	<div class="clearfix"></div>
	{$subcategories}
{else}
{$associated_products}
{/if}

Si y a mieux ou une variable que j'ai louper, je remettrait comme c'etait, reste a voir si ça pose pas d'autres soucis cette modif...

Merci :)

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

dans la configuration du site (administrer/sites.php) avez-vous essayer de changer le paramètre "Méthode pour présenter et compter les produits appartenant à une catégorie. Ce paramètre concerne également les articles et rubriques :" en sélectionnant le bouton radio "Individuelle " ?

Share this post


: post
Share on other sites

Posted · Report post

Bonjour, 

Merci Simon pour cette oriantation, c'est surement ce parametre qui etait a l'origine, j'ai passer sur individuel mais du coups il me manque des elements dans les articles....

J'ai Rubrique "formation en ligne" niveau 1
Dedans j'ai 3 rubriques donc en niveau 2 
Et dans ces 3 rubriques de niveau 2 j'ai des articles.

Du coups quand je suis dans la rubrique de niveau 1, je ne vois pas les liens vers les rubriques de niveau 2 mais j'ai bien les articles dans les rubrique de niveau 2 et niveau 1.

Enfin c'est pas bien grave, la modification faite du coups touche uniquement aux produits mais pas aux articles et leurs rubriques donc je vais laisser en global mais c'est bien ce parametre.

De toute façon je vais passer sur la dernière version et je ferai tous mes tests sur la dernière version ainsi que mes modifications, si je rencontre un soucis ou quelque chose de bizarre je le remonterai.

Merci pour l'info.

 

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping