Votre Formulaire Est Incomplet Ou Comporte Des Erreurs

6 posts in this topic

Posted · Report post

Bonjour,

 

je suis passé sous version 7.2 mais depuis impossible pour les utilisateur de s'inscrire.

 

Effectivement j'ai le message "Votre formulaire est incomplet ou comporte des erreurs." même si tous les champs sont correctement rempli.

 

Je cherche actuellement à résoudre le problème et je suis étonné de ne pas trouver d'information sur le problème.

 

Merci

Share this post


: post
Share on other sites

Posted · Report post

Apres avoir mis ceci: 

var_dump($form_error_object);

j'ai cela sur ma page après avoir cliquer sur le bouton de validation avec tous les champs rempli correctement:

object(FormError)#6 (1) { ["error"]=> array(2) { ["type"]=> string(40) "Vous n'avez pas précisé votre statut. " ["activity"]=> string(43) "Vous n'avez pas spécifié votre activité." } }

Share this post


: post
Share on other sites

Posted · Report post

Je suis arrivé à débloquer la situation mais je sais pas si cela ne pose pas d'autre problème et quel sont les conséquence de ma modification.

 

je suis aller en BO dans les variable de configuration et j'ai modifier comme ceci:

 

 

array

user_mandatory_fields

"prenom" => "STR_ERR_FIRSTNAME", "nom_famille" => "STR_ERR_NAME", "adresse" => "STR_ERR_ADDRESS", "code_postal" => "STR_ERR_ZIP", "ville" => "STR_ERR_TOWN", "pays" => "STR_ERR_COUNTRY", "telephone" => "STR_ERR_TEL", "email" => "STR_ERR_EMAIL", "pseudo" => "STR_ERR_PSEUDO", "token" => "STR_INVALID_TOKEN", "code" => "STR_EMPTY_FIELD"

24/01/2015 19h17:29

core

 

1

 
 
J'ai supprimer se qui porter a référence de mes erreur et maintenant ça fonctionne avec un formulaire entièrement remplis mais j'ai pas fait de test pour le reste, je reste comme ça dans l'attente d'une réponse des pro ;)
 
Merci

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

 

Vous avez fait la bonne modification. Par contre les champs type et activity ne sont pas présent par défaut dans la version 7.2, ni dans la version 7.1. Quelle était la valeur de user_mandatory_fields avant votre modification ?

Share this post


: post
Share on other sites

Posted · Report post

Bonjour, ok merci.

 

En BDD sauvegarder avant de mettre le SQL j'avais ceci:

(242, 'user_mandatory_fields', 'core', 'array', '"prenom" => "STR_ERR_FIRSTNAME", "nom_famille" => "STR_ERR_NAME", "adresse" => "STR_ERR_ADDRESS", "code_postal" => "STR_ERR_ZIP", "ville" => "STR_ERR_TOWN", "pays" => "STR_ERR_COUNTRY", "telephone" => "STR_ERR_TEL"', '', '2013-05-01 12:00:00', '', 1),

Par contre j'ai appliquer ceci pour le passage en 7.2:

-- Ajout de champs obligatoires dans la variable de configuration user_mandatory_fields
UPDATE peel_configuration SET string='"prenom" => "STR_ERR_FIRSTNAME", "nom_famille" => "STR_ERR_NAME", "adresse" => "STR_ERR_ADDRESS", "code_postal" => "STR_ERR_ZIP", "ville" => "STR_ERR_TOWN", "pays" => "STR_ERR_COUNTRY", "telephone" => "STR_ERR_TEL", "email" => "STR_ERR_EMAIL", "pseudo" => "STR_ERR_PSEUDO", "token" => "STR_INVALID_TOKEN", "societe" => "STR_ERR_SOCIETY", "type" => "STR_ERR_YOU_ARE", "activity" => "STR_ERR_ACTIVITY", "code" => "STR_EMPTY_FIELD"' WHERE technical_code='user_mandatory_fields';

Donc ça viens de la... Il ne fallait peut être pas exécuter ces lignes?

 

Merci ;)

Share this post


: post
Share on other sites

Posted · Report post

Bonjour,

 

Le script de migration a été mis à jour, en supprimant les champs activity, type et societe de la liste des champs obligatoire, merci pour votre retour.

Share this post


: post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

Twitter Advisto ecommerce

Facebook PEEL Shopping