Activity Stream

Posts Activity Stream

  1. mayode


    Bonjour,

    Ce qui est très embêtant c'est que cela stoppe le processus du tunnel d'achat qui demande de créer un compte et de le valider, en effet, l'utilisateur met dans son panier et lorsqu'il veut payer il doit crée son compte, alors qu'il devrait continuer son processus d'achat comme dans les autres sites afin qu'il n'ai pas à quitter son panier, je ne sais pas si je suis très clair ?

    Par exemple lorsque vous achetez un produit sur Amazon, et que vous n'avez pas de compte, alors il n'interrompt pas le processus d'achat en demandant de valider son email.

    Merci pour votre réponse

     

  2. mayode


    Bonjour, je l'ai biensûr activé, c'est pour cette raison que je ne comprends pas pourquoi le processus d'achat s'arrête, car le bouton paypal reste inactif.

    Et il est écrit "Merci de votre confiance, votre commande a été enregistrée avec succès" sauf que l'internaut n'a rien validé de l'achat.

    COmment procéder pour que le paiement fonctionne ?

    Merci pour votre réponse

  3. Simon développeur PEEL


    Bonjour,

    Merci, je te souhaite également d'excellentes fêtes de fin d'année.

    J'ai fait les modifications que tu indiques dans ton message, et ça fonctionne sur mon site de test. Donc à priori tes modifications sont bonnes.

    L'erreur 404 a peut-être été gardée en cache de ton navigateur.
    => As-tu essayé la même URL sur un autre navigateur ?

  4. J1P


    Bonjour Simon,

    Tout d'abord je te souhaite plein de bonnes choses pour les fêtes et je te remercie du temps passé à répondre à nos problèmes depuis des années.

    J'ai 1 question concernant l'url rewriting vers 9.3

    Je souhaiterai modifier le chemin http://xxx.com/achat/xxx.html

    en changeant achat par menu

    dans la lib lang j'ai modifié $GLOBALS["STR_MODULE_PREMIUM_URL_ACHAT"] = "achat"; par $GLOBALS["STR_MODULE_PREMIUM_URL_ACHAT"] = "menu";

    ce qui change bien les adresses url mais les pages sont en erreur 404

    j'ai donc modifier htaccess

        RewriteRule ^(buy|comprar|kauf|acquisto|koop)/$ achat/index.php [QSA,L]
        RewriteRule ^(achat|buy|comprar|kauf|acquisto|koop)/cat-(.*)-([0-9]+)\.html$ achat/index.php?catid=$3 [QSA,L]
        RewriteRule ^(buy|comprar|kauf|acquisto|koop)/(.*)\.(.*)$ achat/$2.$3 [QSA,L]

    en

        RewriteRule ^(menu)/$ achat/index.php [QSA,L]
        RewriteRule ^(menu)/cat-(.*)-([0-9]+)\.html$ achat/index.php?catid=$3 [QSA,L]
        RewriteRule ^(menu)/(.*)\.(.*)$ achat/$2.$3 [QSA,L]

    toujours erreur 404

    J'oublies sans doute de changer quelquechose, 1 petite aide ?

    Merci Simon

     

  5. ant0ny


    Rebonjour, je viens aujourd'hui encore de mettre le doigt sur un soucis ou bug ou quelque chose du genre...

    Voici les action sur la commande 20210:
     

    16/12/2020 16h38:13admin_doroEDIT_ORDER-Commande: 20210 Livraison passer sur dispatched
    16/12/2020 14h00:31admin_doroEDIT_ORDER-Commande: 20210 Paiement passer sur completed Livraison passer sur processing
    16/12/2020 13h23:15admin_doroEDIT_ORDER-Commande: 20210 Livraison passer sur processing
    16/12/2020 13h15:24admin_doroEDIT_ORDER-Commande: 20210 Livraison passer sur RESERVES
    16/12/2020 11h30:53AdemaelCREATE_ORDER-Commande: 20210 Paiement passer sur cancelled
    16/12/2020 11h30:50 CREATE_ORDER-Commande: 20210 Paiement passer sur completed
    16/12/2020 11h29:20AdemaelCREATE_ORDER-Commande: 20210 Paiement passer sur pending Livraison passer sur discussed

     

    11h29:20 la cliente crée sa commande
    11h30:50 le site passe le règlement sur réglé.
    11h30:53 3 seconde plus tard la cliente arrive a faire passer son paiement en annulé? a t-elle cliquer sur retour ou fait précédent ou autre chose?
    ensuite on passera en "produit réservé" puis "en cours de traitement" puis je suppose que on aura passé sa commande en réglé manuellement? Puis sera passé en expédier.

    En parallèle, voici les changement sur les tables stock et stock_temp au même moment:

    Date actionActionOLDNEW 
    16-12-20 11:26:08temp insert1919Mise en panier par la cliente
    16-12-20 11:29:20decompte stock1918Validation de la commande on décompte du stock
    16-12-20 11:29:20temp maj1918???
    16-12-20 11:29:20temp maj1819???
    16-12-20 11:30:53remise en stock1819règlement passé sur annuler par la cliente on remet en stock
    16-12-20 11:30:53temp maj1920???
    16-12-20 11:34:49temp del00on vide le stock temporaire
    16-12-20 14:00:30remise en stock1920modification ou ajout de la commande remet et retire immédiatement
    16-12-20 14:00:31decompte stock2019voir ligne du haut

    Finalement au niveau des stock on retire du stock puis on le remet dans le stock donc opération nulle.

    Dans la réalité au niveau de la commande, celle-ci était bien passé en réglé et donc l'article fut envoyé, si qui nous crée ici une erreur de stock entre le stock annoncé sur le site et se que nous avons réellement.

     

    J'essaie de poursuivre mes recherche pour identifier ou et a quel moment un soucis de stock se présente, c'est pas simple car je doit constater un soucis et remonter lors d'un contrôle de stock ou d'un arrivage pour avoir une valeur de référence puis regarder pour chaque changement de stock pourquoi ce changement et si c'est justifié. J'espère que l'on arrivera a ne plus avoir de soucis, toujours contacter les client pour leur dire que nous avons eu un soucis de stock et que l'on ne peut pas leur envoyé la marchandise commandé est assez usant.

    Je vous remercie et vous souhaite de bonnes fêtes de fin d'année.

    Cordialement,
    Denamur Antony

  6. ant0ny


    Bonjour, je reviens pour le même sujet de stock. Alors je sais que depuis vous avez changer de version mais j'ai tellement investi sur cette version et fait de modification que j'ai pas l'envi de tout recommencer. Peut-être un jour quand je m'ennuierai.

    Par contre j'ai toujours eu des soucis de stock et ceci étant très ennuyant, je me suis fait quelques contrôle daté des mouvement de stock. Lors de nos dernière discussion, vous m'aviez conseiller de mettre un délais de réservation du stock lors de la mise en panier, se que j'ai fait et mis sur 300 secondes.

    J'ai mis un contrôle sur ma table stock et stock_temp, on a remis du stock sur ce produit et justement ici nous avons eu une dernière commande validé avec 50pcs commandé alors que réellement il nous en reste que 44pcs....

    Voici le détail des mouvement sur les tables de ce produit:

    Date actionActionOLDNEW
    2020-12-18 14:20:47remise en stock-1034
    2020-12-20 14:41:42temp insert3333
    2020-12-20 14:50:03decompte stock3432
    2020-12-20 14:50:03temp maj3331
    2020-12-20 14:50:03temp maj3133
    2020-12-20 14:55:12temp del00
    2020-12-21 12:01:14decompte stock3231
    2020-12-21 13:57:26remise en stock3169
    2020-12-21 15:30:49temp insert7070
    2020-12-21 15:35:54temp del00
    2020-12-23 00:54:03temp insert6969
    2020-12-23 00:54:49decompte stock6964
    2020-12-23 00:54:49temp maj6964
    2020-12-23 00:54:49temp maj6469
    2020-12-23 00:59:53temp del00
    2020-12-23 20:10:59temp insert6464
    2020-12-23 20:16:35temp del00
    2020-12-27 11:58:16temp insert6464
    2020-12-27 12:02:35decompte stock6444
    2020-12-27 12:02:35temp maj6444
    2020-12-27 12:02:35temp maj4464
    2020-12-27 12:07:55temp del00
    2020-12-27 13:54:08temp insert4444
    2020-12-27 14:00:16temp del00
    2020-12-27 16:44:31temp insert4444
    2020-12-27 16:48:01decompte stock440
    2020-12-27 16:48:01temp maj440
    2020-12-27 16:48:01temp maj050
    2020-12-27 16:53:08temp del00
     

     On vois bien au 2020-12-27 12:02:35 un décompte de stock passant de 64 a 44 lors d'une commande.

    Puis dernièrement on vois un stock temporaire mis (temp insert) à 44 se qui est logique, du moins je pense car techniquement le stock temporaire devrai être le stock restant donc si on en met 44 en panier le stock temporaire devrai être de 0 non? bref c'est un détail et ceci ne pose pas de soucis pour l'instant.
    Ensuite au 2020-12-27 16:48:01 le stock passe de 44 a 0 sauf que la commande en comporte 50 et on peut voir que le stock temporaire a eu une nouvelle valeur à 50... étrange non?

     

    J'ai aussi remarquer que le stock temporaire s'initialise quand on va sur le panier et que l'on a choisi un mode de livraison donc rien n'est fait si le client met des articles en panier, que se passe t-il si plusieurs clients mettent les même articles en panier et qu'il commandes plus que disponible? je pense pas que une vérification soit faite ensuite au niveau du panier.

    J'aimerai avoir votre aide pour pouvoir résoudre mon soucis, ça fait plus de 5-6ans que j'ai cela, j'arrive a avancer et trouver petit a petit d'où cela peut venir mais je connais malheureusement pas le code sur le bout des doigts.

    Je suis en version 7.2.0

    Merci pour votre aide et joyeuse fêtes de fin d'année.

    Cordialement,
    Denamur Antony

  7. Simon développeur PEEL


    Bonjour,

    Pour le premier point concernant la prise en compte du prix, il faut dissocier le symbole du prix affiché. Faire ces modifications nécessite de nombreux changement dans le code. Ce sera corrigé dans la futur version de PEEL.

    Pour le second point, vous pouvez modifier le fichier modeles\peel9\smarty\arbre_rubrique.tpl pour ajouter l'attribut id="{$href|escape:'html'}" dans le lien qui contient l'attribut property="item".

    Pour le troisième point, modifier la prise en compte de la description générale par la description présente dans les onglets nécessite un développement spécifique. Nous pouvons réaliser ce développement pour vous si vous le souhaitez, je vous invite dans ce cas à prendre contact avec notre service commercial.

    Pour le quatrième point : vous pouvez modifier la balise <img dans le fichier smarty\produit_details_html.tpl pour ajouter un attribut

  8. carcy


    Bonjour la communauté !

    une tite question... en relisant les nouveautés de la version 9.3 de peel, j'ai remarqué :

    Pré installation tawk.to

    ça veut dire quoi ?

    En fait moi j'utilise tawk to avec ma boutique, et j'ai installé le script fourni par tawk to dans les paramètres du site, onglet INFOS GENERALES, dans le cadre tags analytics.

    D'ailleurs je ne suis pas sûr que ce soit super super mais bon...

    Donc pour un newbie comme moi, une préinstallation de tawk to, c'est quoi ? un module à rajouter et à acheter chez peel ?

    Merci pour le tuyau !

    JL

     

  9. carcy


    Bonjour à tous.

    Je m'intéresse depuis quelques jours à mon recensement sur google et j'utilise la search console de google qui m'indique pas mal de problèmes. Déjà pas mal sont présents d'avant la version 9.3.0 de peel que je viens d'installer il y a une semaine sans aucun problème.

    Un très grand nombre de problèmes viennent des pages produit "champ price manquant". Avec la nouvelle version, apparemment ce champ est arrivé puisqu'en testant l'URL en direct, l'erreur critique du départ se transforme alors en erreur facultative d'avertissement... En effet, maintenant que le champ price est bien défini, hé bien il est au mauvais format, puisque c'est l'erreur "Format de prix non valide dans la propriété "price" (facultatif) qui prend la place. En effet, pour un prix de 4,20€, la console s'attendrait à avoir 4.20 sans le symbole €. Or ce n'est pas le cas.

    Apparemment, c'est dans le fichier prix.tpl que ça se passe... Est ce que quelqu'un sait comment faire pour corriger ça ?

    Deuxième problème de la search console. Dans ma boutique, j'ai 8 rubriques que j'appellerai "parent", et certaines de ces rubriques (2 d'entre elles) présentent des sous-rubriques. Il y a donc en tout 5 sous-rubriques. Et voilà le problème... alors que je n'ai aucune erreur avec la search console sur les rubriques parents (un champ id existe bien avec le lien de la rubrique concernée), hé bien les 5 sous-rubriques sont impactées par une erreur critique : Champ "id" manquant...

    Est ce que quelqu'un voit comment corriger ce problème ?

    Dernière interrogation, mais peu importante... j'ai 130 produits qui présentent un avertissement "Champ "description" manquant... Pourtant mes 130 produits ont bien une description. Seulement voilà... Ma description se situe au niveau des onglets sur la page produit, et cette description n'est donc pas prise en compte par la console. Donc comment faire pour que ce soit cette description de l'onglet qui soit prise en compte, et non la description "générale" du produit, celle qui s'affiche entre le bloc tarif et la photo du produit ?

    Autre truc tout bête : la console me retourne un avertissement Champ "image" manquant (facultatif)... pourtant chaque produit a bien une photo... ne peut-on pas ajouter quelque part dans le code un class=image ?

    Je vous remercie pour vos différents retours !

    Jean-Luc

     

  10. Simon développeur PEEL


    Bonjour,

    comme indiqué dans le sujet https://forum.peel.fr/topic/16232-connexion-membre/ il faut que le client clique sur un lien présent dans un email qui lui est envoyé.

    comment procéder pour que le compte soit automatiquement validé

     Pour désactiver la validation de l'inscription par email , vous devez créer la variable de configuration suivante depuis la page administrer/configuration.php?mode=ajout  :

    Origine : manual
    Code technique : user_double_optin_registration_disable
    Type : boolean
    Votre contenu : true

  11. Simon développeur PEEL


    Bonjour,

    quand vous dites 'il ne créé pas le compte',
    => Avez-vous vérifier dans la liste des utilisateurs si le compte est présent.

    Lorsqu'une personne s'inscrit elle reçoit un email contenant un lien qui lui permet de valider son compte. Avant cette validation, le compte existe mais est désactivé.
    => Avez-vous regardé dans vos spam si les emails d'inscription sont présent ?

  12. mayode


    BOnjour 

    malgré le fait que j'ai suivi votre procédure => j'ai entré l'email de paypal, le module ne fonctionne toujours pas et j'ai activé le module voir capture. Le moyen de paiement paypal existe et est actif dans administrer/paiement.php mais le paiement s'arrête à l'enregistrement de la commande, c'est tout.

    il y a peut être autre chose à activer. Du coup impossible que le système d'achat fonctionne

    Merci pour votre réponse

  13. mayode


    BOnjour 

    malgré le fait que j'ai suivi votre procédure => j'ai entré l'email de paypal, le module ne fonctionne toujours pas et j'ai activé le module voir capture. Le moyen de paiement paypal existe et est actif dans administrer/paiement.php mais le paiement s'arrête à l'enregistrement de la commande, c'est tout.

    il y a peut être autre chose à activer. Du coup impossible que le système d'achat fonctionne

    Merci pour votre réponse

    Capture d’écran 2020-11-27 à 19.45.12.png

  14. mayode


    Lorsqu'un utilisateur a créé un compte il est impossible de se connecter pour un nouvel utilisateur si l'administrateur du site n'active pas son compte... comment procéder pour que le compte soit automatiquement validé ? car si un internaute achète un produit et crée un compte ça veut dire qu'il ne peut pas se connecter et acheter si l'administrateur du site n'a pas valider son client.

    Merci pour vos réponses !

    Cordialement

  15. mayode


    Bonjour

    lorsque je crée un compte, impossible de m'y connecter et lorsque je demande à récupérer le mot de passe, cela répond "Cette adresse électronique n'existe pas." alors que je l'ai créer. Il n'y a aucun mail me demandant de valider ce compte non plus donc je ne sais pas si il a été créé.

    J'ai essayé avec d'autre email et idem il ne créé pas le compte, par contre il me fait remplir pleins de champs mais sans aboutissement ce qui est problématique si un client veut acheter un produit.

    Je vous remercie pour votre réponse, Cordialement

Twitter Advisto ecommerce

Facebook PEEL Shopping