J1P

Utilisateur open source
  • Content count

    148
  • Joined

  • Last visited


Posts posted by J1P



  1. Le modele email récupère [BOUGHT_ITEMS] dans lequel se trouve les produits et le total de la commande

    Pour le $GLOBALS["STR_TTC"] = ""; il y est bien vide dans le lib/lan/en.php

    Pour le caddie pop up j'ai modifié   <td class="center">{if $display_prices_with_taxes_active}{$total} {$STR_TTC}{else}{$total_ht} {$STR_HT}{/if}</td>

    de cart_popup_content.tpl  et cela semble fonctionner

    Il ne me reste qu'à trouver pour le [BOUGHT_ITEMS] des emails clients ou le modifier.


  2. Bonjour Simon,

    J'espère que tu vas bien après cette vague de virus. Je suis sur la version 9.3 et je souhaiterai enlever incl. VAT sur mes pages anglaises, j'ai donc supprimé dans lang toute référence , ce qui m'efface le incl. VAT dans pas mal d'endroit mais il en reste par exemple

    1) sur achat/fin_commande.php le total juste en dessous de la date

    2) dans l'email que recoit le client (dans la partie résumant sa commande) ex: Qty : 1 Price : 23 incl. VAT

    3) dans le caddie celui qui s'affiche en pop up après avec choisi son produit pas celui du petit cart en haut de page

    Je cherche dans les TPL mais je ne trouve pas. Peux-tu m'aiguiller ?

    Merci de ton soutien

    Anh



  3. Bonjour Simon,

    J'ai effectué les tests sur différents browsers vidant les caches mas malgré mes modifs, je ne peux pas changer achat/buy en menu.

    Je vais faire un transfert de peel 9.3 sur un autre serveur pour voir si cela fonctionne, cela peut etre due au hosting car l'erreur 404 signifie qu'il ne trouve pas la page / redirection.

    Si ca marche pour toi ca devrait marcher pour moi aussi


  4. Bonjour Simon,

    Tout d'abord je te souhaite plein de bonnes choses pour les fêtes et je te remercie du temps passé à répondre à nos problèmes depuis des années.

    J'ai 1 question concernant l'url rewriting vers 9.3

    Je souhaiterai modifier le chemin http://xxx.com/achat/xxx.html

    en changeant achat par menu

    dans la lib lang j'ai modifié $GLOBALS["STR_MODULE_PREMIUM_URL_ACHAT"] = "achat"; par $GLOBALS["STR_MODULE_PREMIUM_URL_ACHAT"] = "menu";

    ce qui change bien les adresses url mais les pages sont en erreur 404

    j'ai donc modifier htaccess

        RewriteRule ^(buy|comprar|kauf|acquisto|koop)/$ achat/index.php [QSA,L]
        RewriteRule ^(achat|buy|comprar|kauf|acquisto|koop)/cat-(.*)-([0-9]+)\.html$ achat/index.php?catid=$3 [QSA,L]
        RewriteRule ^(buy|comprar|kauf|acquisto|koop)/(.*)\.(.*)$ achat/$2.$3 [QSA,L]

    en

        RewriteRule ^(menu)/$ achat/index.php [QSA,L]
        RewriteRule ^(menu)/cat-(.*)-([0-9]+)\.html$ achat/index.php?catid=$3 [QSA,L]
        RewriteRule ^(menu)/(.*)\.(.*)$ achat/$2.$3 [QSA,L]

    toujours erreur 404

    J'oublies sans doute de changer quelquechose, 1 petite aide ?

    Merci Simon

     


  5. Bonjour Simon,

    Sur les pages "catégorie" le titre (juste au dessus de administrer la catégorie) est composé de :

    Titre + meta titre de la catégorie hors ce meta titre est tronqué et enlève certains mots et chiffres

    A quel endroit le modifier soit pour supprimer le meta titre soit pour l'afficher entièrement

    Je suis sous la version 9.3

    Merci

     


  6. Bonjour Simon,

    malgre tous ces bons conseils et de nombreux tests, je n'arrive pas a trouver d'ou peut provenir cet euro, n'y a t'il pas 1 endroit dans le code ou il y a une reference a l'euro du style devise par defaut dans le code source ? (autre que l'option choisir la devise par defaut)

    Car dans l'email de confirmation le montant + devise est bon

    Cet euro apparait juste dans achat/historique_commandes.php et fin de commande, je ne comprends pas.

    Je continues mes tests, si vous avez des idees, je suis preneuse, merci Simon

    Je viens de penser a 1 truc, a l'installation j'ai choisi la boutique pre-remplie et non vide, est-ce que cela pourrait venir de la ?


  7. Bonjour Simon

    Je rencontre un probleme sur la version 9, j'ai defini une seule devise dans l'admin qui est le VND.

    Lorsque je teste et passe commande j'ai bien la devise VND qui apparait sur toutes les pages, dans le caddie sur la page achat/caddie_affichage.php et jusqu'a achat/achat_maintenant.php hors quand je valide sur cette page et donc que j'arrive sur la page achat/fin_commande.php la devise est modifiee en euro (qui n'est pas presente dans ma liste de devise par ailleur).

    De ce fait lorsqu'on regarde le suivi des commandes aussi bien cote client que dans l'admin on a la devise euro qui apparait.

    Une idee comment corriger ce probleme ?

    J'ai vide mes caches et fait des tests a partir de plusieurs browsers, de plus je n'ai defini qu'une seule devise sur le site.

    En regardant resume_commande.tpl on s'apercoit bien que {$order_amount} reprend le montant de la commande incluant la devise hors je ne comprends pas pourquoi ce changement surtout sur une devise qui n'est pas disponible sur le site. Une idee Simon ?

     


  8. Bonjour Simon,

    Non je pense qu'il y a autre chose a modifier, lorsque je fais des tests d'inscription d'un nouveau client malgre le fait que la fonction send_mail_for_account_creation soit en commentaire, cela ne change en rien le process.

    Le status du client est a 0 c'est a dire qu'il ne peut pas se connecter sans avoir a valider le lien dans l'email.

    J'ai cherche ou etait la valeur 0 de l'user profile "util" mais je n'ai pour l'instant pas trouve. Mon but etant simplement d'accepter toute inscription sans avoir a valider via un lien par mail pour pouvoir commander directement en ligne.


  9. Bonjour Simon,

    Je ne comprends pas tres bien pour empecher l'envoi d'email

    La modification doit elle se faire sur utilisateurs/enregistrement.php ? en ligne 214 ?

     

    $id_utilisateur = insere_utilisateur($frm, false, !empty($GLOBALS['site_parameters']['user_register_send_password_by_email']), true);
            if (empty($GLOBALS['site_parameters']['user_double_optin_registration_disable'])) {
                // on récupère les informations sur l'utilisateur qui vient d'être enregistré en BDD pour pouvoir créer le hash qui sécurisera la validation du compte
                $sql = "SELECT *
                    FROM peel_utilisateurs
                    WHERE id_utilisateur = '" . nohtml_real_escape_string($id_utilisateur)."'";
                $query = query($sql);
                $result = fetch_assoc($query);

     

    sur la version 6.2 nous avions directement un echo get_user_register_success($frm); donc c'est pour cela que je suis un peu perdu

    Un petit coup de main sur cela ?

    Merci

    Anh

     

     


  10. Bonjour Simon,

    Je suis sur la nouvelle version 9 et forcement entre la 6.2 et la 9 tout est bien different.

    J'ai donc lu les anciens messages du forum mais je ne trouve pas les solutions.

    Par exemple sur le formulaire d'enregistrement (inscription), je souhaiterai enlever beaucoup de champs avec etoiles.

    Simon vous disiez de regarder dans administer/configuration user_mandatory_fields mais sur la version 9 il n'y a pas donc j'imagine que ca a du migrer ailleur.

    Ou puis-je enlever les obligations de champs? la mise en page de la page se trouve sur user_register_form.tpl et sur utilisateurs/enregistrement.php il y a bien user_mandatory_fields mais cela ne semble pas affecter les obligations.

    Le formulaire envoie un message de confirmation au client, ou peut-on enlever cette option car les messages n'arrivent pas toujours ou vont dans les spams.

    Merci


  11. Bonjour

    Je voudrais changer la presentation des attributs en checkbox.

    Sur critere_stock.tpl il y a bien la configuration de Size et Color mais pas des attributs.

    A quel endroit puis-je trouver le <td class="attribut-cell"> pour modifier le tableau des attributs afin de ne pas avoir 2 colonnes.

    En effet lorsque le titre de l'attribut est long, la colonne des checkboxes est trop petite.

    Merci d'avance

    Je suis sur la derniere version 9


  12. Bonjour Gilles, je reviens sur ce sujet car je n'ai pas trouve la solution pour le moment. J'ai suivi votre conseil, je comprends que dans la partie meta $product_images n'est pas défini. Vous dites d'utiliser la methode get_product_main_picture().

    J'ai trouve sur display_product

    if (!function_exists('get_product_in_container_html')) {
    function get_product_in_container_html(&$product_object, $only_show_products_with_picture = true)
        {
            $output = '';
            if (!empty($product_object->id) && !empty($product_object->etat)) {
                $urlprod = $product_object->get_product_url();
                $display_picture = $product_object->get_product_main_picture();

     

    par contre je ne comprends pas comment appliquer cela entre mes balises meta

    <meta property="og:title" content="' . trim(strip_tags(String::html_entity_decode_if_needed(str_replace(array("\r", "\n"), '', $m['meta_titre'])))) . '" />
    <meta property="og:description" content="' . $meta_desc . '" />

    <meta property="og:image" content="' . $GLOBALS['repertoire_upload'] . '/' . $product_images[1] . '" />

    Un petit coup de main s'il vous plait

    Merci beaucoup

    Anh


  13. Bonjour,

    une autre petite question sur ce moteur de recherche dans l'admin (je suis sous version 6.2), si on veut faire une recherche globale sur tous les utilisateurs, on ne selectionne aucun profil mais l'admin apparait dans ce listing, peut-on ne pas faire apparaitre l'admin dans ce listing ? Mon but etant de donner l'acces a des redacteurs qui peuvent chercher n'importe quel utilisateur mais ils ne devraient pas pouvoir voir ou modifier les admin.

    Merci de votre soutien


  14. Bonjour à tous,

    Tout d'abord meilleurs voeux à tous pour cette nouvelle année 2016.

    J'ai une petite question relative au moteur de recherche utilisateurs. Je suis sous la version 6.2. le moteur de recherche permet dans l'admin de rechercher un utilisateur selon différents critères comme nom, prenom, code postal, email

    Je voudrais ajouter le critère "societé", à quel endroit dois-je modifier ? En effet pour le moteur de recherche côte client, il faut modifier le fichier search mais côté admin ce n'est pas le même moteur.

    Merci de votre aide

    Anh

     


  15. Bonjour Gilles,

    Non lorsque je regarde mon code source il apparait seulement <meta property="og:image" content="http://xxx.fr/upload/ " /> c'est a dire que dans mon entete $product_images[1]  n'est pas compris ou mal geree dans l'html.

    Je ne comprends pas trop car j'utilise sur une autre page dans un slideshow ' . $GLOBALS['repertoire_upload'] . '/' . $product_images[1] . ' et j'ai bien mon image qui apparait, donc en theorie dans le <head> l'url de l'image devrait aussi s'afficher, non ? ou je fais une erreur de logique ?

    En effet sur facebook developper ils conseillent meme une taille de 600x315 pixels voir 1200x630, je suis les conseils sur https://developers.facebook.com/docs/sharing/best-practices#tags

    Merci Gilles de vos lumieres

    Anh

Twitter Advisto ecommerce

Facebook PEEL Shopping